How to make obs flatpak run record screen under wayland?

I recently made the decision to always opt for flatpak whenever possible. All applications worked like esparo, with the exception of OBS. I use wayland, and I don’t intend to use X11; In itself, using OBS under Wayland already seems to cause some inconveniences, however, this seems to be an issue that has been overcome by the OBS developers, requiring just a few steps to work correctly.

However, in my experience with flatpaks, the solutions and support are not solving my problem (which probably comes from the sandbox approach), there is certainly a solution and resources for this, but I don’t know how to put it into practice.

Reading the forums I realized that the solution revolves around the flatpak portal framework, and the resources for this approach are xdg-desktop-portal and this solution from Georges: Sign in · GitLab -xdg-portal/ (something I believe is an OBS extension).

That said, what should I do to be able to record my screen using OBS on Flatpak under Wayland?

P.S.: My PC has a Ryzen 3 3250u with an integrated Vega 3 GPU using the open-source Video Linux driver. Additionally, the only screen recording option I have access to running under wayland is pipewire, but this generates a black screen recording.

A generally bad decision, in my opinion;
especially with the xdg-portal issues affecting flatpak of late.

While I’m uncertain whether your specific issue will be solved by this, I would generally suggest using OBS-Studio from the official repositories, as I do (albeit on KDE rather than Gnome) in Wayland.

  • Completely remove your flatpak version of OBS-Studio.
  • Install OBS-Studio from the repos:
sudo pacman -S obs-studio

It just works (for me) out of the box.

Ok, thanks for your answer, but I’ll keep looking to resolve this in flatpack

Good luck. :slight_smile:

I recommend the exact opposite when it comes to specifically OBS.
Everything related to Chrome (f ex pipewire capture) will NOT work on the Manjaro version, flatpaks, no problem.

As for your problem with wayland, I sadly have no input. But moving to the Manjaro repositories I do NOT think is the answer.
Just so you know.

Fortunately, I have found a solution to my question. It worked after performing two specific actions: firstly, uninstalling the dedicated Intel graphics libraries (which seemed odd since I primarily use AMD); secondly, simply installing pacman’s xdg-portal-wrl.

Regarding the presence of libraries associated with Intel graphics, I must admit it initially appeared nonsensical. However, I stumbled upon reports suggesting that this approach resolved issues related to screen sharing within certain programs.

The wlr (Wayland compositor) truly provides a solution to the problem I encountered. It is specifically designed to manage portals in Wayland and other wlroots-based environments.

I would highly recommend that anyone seeking to utilize integrated or more advanced features within a sandbox environment refer to the table of backend interfaces and their corresponding functionalities (accessible at: XDG Desktop Portal - ArchWiki ). This resource can assist in selecting the most suitable and adequately functional option.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.