How to make num lock turn on on startup?

A very basic and simple question.
Every time I turn on my computer the num lock is off
How can I set num lock on by default?

1 Like

There are different stages where you can enable this, but best is to enable this everywhere.

  1. Make sure that the UEFI or BIOS enables NumLock.

  2. In /etc/sddm.conf, make sure that you have…

[General]
InputMethod=
Numlock=on
  1. In KDE Plasma, open up System Settings and navigate to Hardware, Input Devices, Keyboard. There is a setting there for automatically turning on NumLock.

  2. If you want NumLock to always be active in Plasma, even when it’s switched off — i.e. the indicator LED on the keyboard is off — then select the Advanced tab in the System Settings section referenced here-above, and tick the checkbox for “Compatibility Options”, “Numeric keypad always enters digits (as in macOS)”.

  3. If you also want to enable NumLock in tty sessions, install systemd-numlockontty from the AUR. :arrow_down:

pamac build systemd-numlockontty
sudo systemctl enable --now systemd-numlockontty
8 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.