How to make a Kernel default?

I have 3 kernels installed (5.8.6-1, 5.4.64-1 and 4.19.144-1)
I want to make the last LTS Kernel (5.4.64-1) default, but if i don’t choose it each time on GRUB it starts with the latest (5.8.6-1).

You can select the kernel in the GRUB menu under advanced settings. That should make it your default.

verify the file /etc/default/grub - it should contain lines like this

GRUB_DEFAULT=saved

...

GRUB_SAVEDEFAULT=true

...

Then depending on your latest choice it will always start on the saved entry.

I have those lines on GRUB but like i said if i start Manjaro without going to advanced options it starts with the latest kernel.
Also, i can’t remove it, maybe it has to do with this, when trying to remove it through manjaro settings manager:

linux58
linux58-virtualbox-host-modules

Starting
checking dependencies…
:: removing linux58 breaks dependency ‘linux58’ required by linux-latest
error: failed to prepare transaction (could not satisfy dependencies)

Done …

For the time being linux58 is linux-latest - and probably the package linux-latest is installed. Have you tried to remove it using pacman?

sudo pacman -Rns linux-latest
2 Likes

Thank you, i removed linux-latest and after i could remove linux58.
However GRUB continues to assume still the latest kernel available (now 5.4.64-1) as default, but for the time being it works for me :wink:

I have a similar problem, I installed mikah 20.1 xfce a week ago without problems
checking the kernel found it was running 5.8.6-1 I installed the latest LTS 5.4.64-1 but I can only select it in the GRUB menu under advanced settings; it will not save as default.
I checked the grub file and it contains ```
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

I have had no problems so far but should I try and remove the latest kernel
as I would prefer to use a recommended one while I learn manjaro linux