How to install wayland on KDE?

I’ve been hearing a lot of good things about Wayland lately, I want to try it too, but I don’t have it in my system load. How can I add it
image

Install plasma-wayland-session :wink:

1 Like

(and select wayland session from SDDM before login)

If you use nvidia you probably need to enable DRM KMS as well:
https://wiki.archlinux.org/title/NVIDIA#DRM_kernel_mode_setting

1 Like

It worked, I was able to get wayland running. But in wayland my system did not work and the screen just turned gray and froze

will try

    ~  sudo pacman -S nvidia-dkms                                                                                                                                                                                                   ✔ 
[sudo] password for alexbespik: 
resolving dependencies...
looking for conflicting packages...
:: nvidia-dkms and linux515-nvidia are in conflict (NVIDIA-MODULE). Remove linux515-nvidia? [y/N]

Will it degrade the performance of the system?

Why are you doing this?

IF you think it is the same as this suggestion, please refrain.
I did not suggest installing nvidia-dkms and it is not the same as setting DRM KMS.

There are a number of ways to achieve this, as outlined at the arch wiki.
One would be to add the following to the options of /etc/default/grub:

nvidia_drm.modeset=1 nvidia_drm.fbdev=1

(and run sudo update-grub)

You maye also want to add nvidia, nvidia_modeset, nvidia_uvm, nvidia_drm to the modules line of /etc/mkinitcpio.conf

1 Like

   ~  sudo update-grub  :heavy_check_mark:  12s 
/etc/default/grub: line 63: nvidia_drm.modeset=1: command not found

Where did you put the options?

Probably the wrong place.
These would all go on GRUB_CMDLINE_LINUX … near the top.
ex:

GRUB_CMDLINE_LINUX="nvidia_drm.modeset=1 nvidia_drm.fbdev=1"
1 Like

After that system is not booting (snapshots doesnt helps how to bring it all back?

I did all of this

I dont know if there was an accident in applying the thing or not.
In any case you should be able to edit the options from grub. Or drop to TTY or boot into runlevel 3 and edit from there.

From grub, highlighting your selection, hit e and you can remove the lines.
(F10 or Ctrl+x to exit and continue booting)
Do note that this method is temporary - once in make permanent changes.

Otherwise you can see here:

Yes system is boot normal Thanks
Wayland is still not working

Sorry, best I could do is parrot the arch wiki.
I am not all that familiar with nvidia or wayland. :face_with_peeking_eye:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.