How to install (up-to-date) bumblebee?

I’ve noticed that recently MHWD only has options for Nvidia-Prime and Nvidia (standalone) whereas the options for Nvidia-Bumblebee are no longer being updated (last one being version 430, whereas current version is 455)

Now I know prime is real nice stuff, but there are cases where you would actually want to use bumblebee.

For instance for GPU passthrough in laptops it is pretty much required unless you want to just have no access to the nvidia gpu in the host machine (which is exactly my particular corner case)

How do I set up bumblebee on Manjaro with up to date drivers right now?

It was actually a pretty simple deal to go from prime to bumblebee.

I made a simple bash script that installs/uninstalls bumblebee.

linuxstring=linux$(uname -r | cut -d '.' -f-2 | tr -d .)

if [ "$1" = "--install" ] || [ "$1" = "-i" ]; then
	sudo pacman -S primus bumblebee $linuxstring-bbswitch primus_vk lib32-primus lib32-primus_vk
	sudo systemctl enable bumblebeed

	echo "Bumblebee will be enabled after a restart"
elif [ "$1" = "--uninstall" ] || [ "$1" = "-u" ]; then
	sudo systemctl disable bumblebeed
	sudo pacman -R primus bumblebee $linuxstring-bbswitch primus_vk lib32-primus lib32-primus_vk

	echo "Bumblebee has been disabled and uninstalled, please restart for changes to take full effect."
	echo "Please type -i or --install to install bumblebee, or -u or --uninstall to uninstall bumblebee."

I have two remaining problems though.

1: Primus_VK does not seem to work right (I made a separate thread for this, but this piece of garbage new forum version will not allow me to link to it)
2: bbswitch does not seem to work, I cannot turn off the dGPU after it has been turned on, But when the computer initially boots the dGPU will start in the ‘off’ mode. For GPU Passthrough purposes this essentially means that I can start the passthrough VM as long as I have never used the dGPU for anything on the host (e.g. never used optirun/primusrun/pvkrun for anything). I tried to use acpi_call as an alternative to bbswitch but on there I just get a permission denied error so this issue is entirely unsolved right now.

It’s worth noting that there is no need to remove the xorg.conf files for the prime setup for bumblebee to work, I’ve tried both running it with and without those files and there was no appreciable difference in how the machine operated.

Update: Apparently the primus_vk package in the official repositories is broken, installing primus-vk-git from aur solved the first issue, although the intel vulkan driver remains broken, at least pvkrun will work as normally intended.

Still since bbswitch seems to be kinda iffy on working, I don’t know if the powersaving abilities of bumblebee are working or not (I presume not).

Since I’ve been doing gpu passthrough, I found out a way to unbind the nvidia card from the nvidia drivers, when the card is not bound to the driver, bbswitch will work, but by then it’s kind of a moot point, unfortunately unbinding the card with Prime enabled will not work.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.