How to install the Plasma Vaults feature?

Hi!

I have seen the screenshots from here and I wish to try it since I use cryfs (I currently use a shell command to mount the cryfs and open Dolphin and other one to unmount it, but I think these commands are not that bug-free as a KDE integration would be. I tried Alt+Space and Super keys and typed in there vault or seif as it is if translated in my language and I can’t find this feature.

System information

██████████████████ ████████ silviub@silviu-omenbyhplaptop17cb0xxx
██████████████████ ████████ -------------------------------------
██████████████████ ████████ OS: Manjaro Linux x86_64
██████████████████ ████████ Host: OMEN by HP Laptop 17-cb0xxx
████████ ████████ Kernel: 5.8.18-1-MANJARO
████████ ████████ ████████ Uptime: 1 hour, 22 mins
████████ ████████ ████████ Packages: 1408 (pacman), 5 (snap)
████████ ████████ ████████ Shell: fish 3.1.2
████████ ████████ ████████ Resolution: 3840x1200, 1920x1080
████████ ████████ ████████ DE: Plasma 5.20.3
████████ ████████ ████████ WM: KWin
████████ ████████ ████████ Theme: Breath2 [Plasma], Breath [GTK2/3]
████████ ████████ ████████ Icons: breath2 [Plasma], breath2 [GTK2/3]
████████ ████████ ████████ Terminal: konsole
Terminal Font: Noto Mono 10
CPU: Intel i7-9750H (12) @ 4.500GHz
GPU: NVIDIA GeForce RTX 2060 Mobile
Memory: 5450MiB / 15886MiB

Thanks!

Install package:

plasma-vault

It will be accessible via systray. It may be hidden so if it doesn’t show up, right-click on the triangle on the system tray, choose system tray settings, find it on the list and make it visible at all times.

If you need it in dolphin through right-click, go to dolphin settings, services, mark vault entry.

2 Likes

Hi!

  1. Is it possible to use an existing cryfs directory as a vault?
  2. How do I use the Dolphin integration? It is enabled, but I do not see any new right-click context menu item on my cryfs encrypted directory.

I am going to restart the system since I just restarted KDE until this moment and I hope this works.

Thanks!

I have rebooted the computer and I still don’t see how to use the Dolphin integration.

You are correct. I also can’t see any dolphin option, although I enabled it. I don’t have an answer to that I’m afraid. Maybe it’s a bug or something else must be done. If the latter is true, the implementation sucks, as it should be easily self discoverable.

It’s worth to submit this issue to bugtracker, especially if you use the vault. I don’t have much usage for this feature at the moment.

1 Like