How to install NZBGET in Manjaro?


I’m having difficulties installing NZBGET on Manjaro XFCE.

SABNZBD installed and functions with no problems.

I have searched this forum, and Google, but have not found a clear, and concise answer.

I have also read the Wiki on this topic, but again, it is not clear and concise for me to understand.

Thanks in advance for any help.

maybe I should edit my post.

NZBGET installs fine, but I cannot open/run it.

I successfully installed SABNZBD, and I can open/run it without any problems.

I just cannot figure out how to successfully install/open/run NZBGET on Manjaro.

I have seen other questions about this on other forums, however, there does not seem to be any answers in layman’s terms.


Hi Aragorn,

Thanks for your help.

I was able to open the web interface via the terminal commands on the Wiki, but I have no idea how it happened.

For example: in the Wiki, it states to do the following things:

"Update the configuration before starting NZBGet:



Make sure the permissions are set correctly:

chown -R nzbget:nzbget /var/lib/nzbget

chmod -R 750 /var/lib/nzbget"

How exactly do I do this?

This is the trillion dollar question that would make life so much easier for many Linux users around the globe.

Do have a step by step list of commands that I should input in the terminal to accomplish the above task(s)

thanks for any help

Those are commands, to be executed in a terminal window, and you’ll have to do that with elevated privileges, because /var/lib is not writable to unprivileged users. :arrow_down:

sudo chown -R nzbget:nzbget /var/lib/nzbget
sudo chmod -R 750 /var/lib/nzbget

Thanks Aragorn,
I was able to use NZBGET and download an .NZB file, but I have no idea where the Downloaded/unpacked file is located.

Is there a way to choose the destination of downloaded/unpacked files?


If you downloaded it as an ordinary user, then logic dictates it would be in your ~/Downloads folder.

The documentation should tell you that. :stuck_out_tongue:

Thanks again Aragorn,

How exactly would I know if I downloaded it as an ordinary user?

Which part of the documentation should I look for downloaded file destination?


I don’t know how that software works, but presumably you would be downloading those files via a web browser or some other userspace application. It would be the most logical way.

If you read it, you will know. :stuck_out_tongue:

I am having some problems on Manjaro KDE.
So far, have done the following steps successfully
Edit: Installed from manjaro repository.

    ~  nzbget -v                                                                                                 ✔
nzbget version: 21.1
    ~  sudo mkdir /var/lib/nzbget                                                                                ✔
[sudo] password for user:
    ~  mkdir /var/lib/nzbget/.nzbget                                                                     ✔  13s 
mkdir: cannot create directory ‘/var/lib/nzbget/.nzbget’: Permission denied
    ~  sudo mkdir /var/lib/nzbget/.nzbget                                                                      1 ✘
    ~  sudo cp /usr/share/nzbget/nzbget.conf /var/lib/nzbget/.nzbget                                                         ✔
[sudo] password for user:
     ~  kate /var/lib/nzbget/.nzbget/nzbget.conf

I followed this ( I am stuck here…

sudo chown -R nzbget:nzbget /var/lib/nzbget

What now ?

probably somewhere in the documentation is mentioned that a new user and/or group nzbget have to be created

The message means that there is no such user and thus the ownership cannot be changed to that user.

1 Like

so, just after installing…

then, did these steps…

   ~  sudo useradd nzbget                                                                                                   ✔
[sudo] password for user:
    ~  id nzbget                                                                                                      ✔  9s 
uid=1001(nzbget) gid=1001(nzbget) groups=1001(nzbget)
    ~  sudo chown -R nzbget:nzbget /var/lib/nzbget                                                                           ✔
[sudo] password for user:
    ~  sudo chmod -R 750 /var/lib/nzbget                                                                             ✔  19s 
    ~  sudo nzbget -c /var/lib/nzbget/.nzbget -D                                                                             ✔
    ~ 

after the change…
If those steps were correct, what to do now ?

… you will eventually notice that none of your links are actual links
and that the second to last one doesn’t go anywhere …? :sunglasses:

Sadly, that’s the forum’s policy. I can’t paste/include links in this post. :person_shrugging:

just as an example I took your post
and changed it
so that the link (and only the link) is formatted as blockquote
This will also work as a new member.

and this is what it looks like with the one I was referring to:

it goes nowhere

btw: I did not read the documentation or tried setting this up myself
so I cannot really help with whatever issue it is that you have

Solved!! Credit: Squigs.
Thank you all.

Hi cyberchaser,

Which specific posts/commands did you use to successfully install and run/open NZBGET?

For example, did you follow “kevinelekiller” post…or a different one?

If you did follow “kevinlekiller” instructions…do have specific instructions on how are steps 1 and 2 accomplished? For example, if my username is “Bob”, what specific commands would I execute ? Thanks

1. sudo chown "$USER:$USER" "$HOME/.nzbget"

Edit the config file:

2. nano "$HOME/.nzbget"

“edit the config file”…nano “Home/.nzbget” … how exactly do I do this?

edit is kind of vague.


To edit the mentioned file:

nano -w <your home folder>.nzbget

Hi @dude_1776 I have updated that Reddit post. You can check it. I have explained it there. After that if u get any queries I will try to answer.
Good luck.