How to install muwire?

I’ve tried installing muwire from pamac but I got a pgp import error. I managed to solve it by using the command that I found here, gpg --keyserver --recv-key A72832072D525E41.

Now I’ve tried again and I’ve gotten another error:

Cloning muwire build files...
Generating muwire information...
Checking muwire dependencies...
gpg: key A72832072D525E41: public key "Zlatin Balevsky (Personal key) <>" imported
gpg: Total number processed: 1
gpg:               imported: 1

Resolving dependencies...
Checking inter-conflicts...

Building muwire...
==> Making package: muwire 0.8.12-1 (lun 20 jun 2022 16:28:02)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating muwire git repo...
Fetching origin
  -> Found muwire.desktop
  -> Found
==> Validating source files with sha256sums...
    muwire ... Skipped
    muwire.desktop ... Passed ... Passed
==> Verifying source file signatures with gpg...
    muwire git repo ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of muwire git repo...
Cloning into 'muwire'...
Switched to a new branch 'makepkg'
==> Starting build()...

Welcome to Gradle 7.4.2!

Here are the highlights of this release:
 - Aggregated test and JaCoCo reports
 - Marking additional test source directories as tests in IntelliJ
 - Support for Adoptium JDKs in Java toolchains

For more details see

Starting a Gradle Daemon (subsequent builds will be faster)
> Task :cli-lanterna:clean UP-TO-DATE
> Task :host-cache:clean UP-TO-DATE
> Task :update-server:clean UP-TO-DATE
> Task :pinger:clean UP-TO-DATE
> Task :core:clean UP-TO-DATE
> Task :gui:clean UP-TO-DATE
> Task :mwmodules:clean UP-TO-DATE
> Task :cli:clean UP-TO-DATE
> Task :cli:processResources NO-SOURCE
> Task :host-cache:compileJava NO-SOURCE
> Task :cli-lanterna:processResources NO-SOURCE
> Task :update-server:compileJava NO-SOURCE
> Task :mwmodules:processResources NO-SOURCE
> Task :pinger:compileJava NO-SOURCE
> Task :gui:griffonManifest
> Task :gui:processResources
> Task :core:compileJava FAILED
> Task :pinger:compileGroovy
> Task :update-server:compileGroovy
> Task :host-cache:compileGroovy

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':core:compileJava'.
> Could not find tools.jar. Please check that /usr/lib/jvm/java-8-openjdk/jre contains a valid JDK installation.

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.


14 actionable tasks: 6 executed, 8 up-to-date
==> ERROR: A failure occurred in build().

muwire requires java-runtime>=11, but apparently you have 8 set as default. See Java - ArchWiki and this comment:

You need java11 to build and use this package. The current upstream version (0.8.10) does not work with java17. Don’t forget to configure java11 as the default JVM with archlinux-java.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.