How to install Manjaro ARM on emmc properly? Orange Pi 5 Plus doesn't boot

Hello! I can’t figure out how to install Manjaro arm on Orange pi 5 plus to emmc. It does’t boot, just black screen!
I use dd to write images to sd-card
xzcat Manjaro-ARM-sway-opi5-plus-20240520.img.xz | pv | dd of=/dev/sdd bs=4M
Sway, mate, minimal editions boots well from sd-card. Gnome and plasma have graphical issues.
Then I install Manjaro arm to emmc with
manjaro-arm-flasher
tool. And a black screen. Armbian with
armbian-config
installs to emmc and boots perfectly. But not Manjaro. Do I miss something?

1 Like

Please don’t flash it on emmc yet as these are all development images as mentioned in the realease title.

It is not a complete image and does not have hdmi output yet.

This is not an official image cause we needed added support for opi5 plus.

Where did you get this from?.

1 Like

Got it from github
https://github.com/manjaro-arm/opi5-plus-images/releases

Ok thats done by me and yes there is no hdmi in those images.

I will start working on new patches from upstream soon and get some rk3588 images with hdmi.

2 Likes

That would be great! rk3588 is the most powerful arm cpu right now, right? With kernel upgrade from 5.10 it’s a beast! No overloading, no overheating (I have ~50C in aluminum case without any fan; it boiled up to ~80C before!), no lagging (4k without drops). Amazing old x86 pc replacement!

These is! I got it worked! An manjaro’s manjaro-arm-flasher tool writes without sudo permission, that causes no booting from emmc. Writing with sudo dd directly to emmc makes sway, mate and xfce images work, but booting time is so long.

The minimal image doesn’t allow to install any package, giving

invalid or corrupted package (PGP signature)

error.

Plasma & gnome images gives gpu issue: impossible to see anything.

:pray: for opi5-plus support! rk3588 is a monster!

Hi, Just checking what is the kernel used in Release Dev 20240520 · manjaro-arm/opi5-plus-images · GitHub? Is it still linux-rk3588-6.7-rc3-4?

Yes, it is. What’s the latest kernel for rk3588?

Was hoping Manjaro releases a newer kernel for RK3588. The last I tried kernel linux-rk3588-6.7-rc3-4 with KDE Plasma/Gnome, HDMI output was available but USB 3.0 ports were not supported then – this in December 2023/Jan 2024 time frame.

KDE Plasma/Gnome with kernel-6.7-rc3-4 was working ok without GPU HW acceleration or USB 3.0 support.

Do have a working Manjaro-Opi5-Plus with GPU and VPU hw acceleration support but uses bsp-kernels. This is NOT officially supported by Manjaro, so not sure I can/should discuss here with details.

1 Like

New Dev 20240610 image, testing Plasma now, works! New 6.9 kernel, wayland, great!
Orange Pi wireless module R6, that based on Realtek RTL8852BE-CG, doesn’t work out of box, but I have working manjaro with wayland on emmc (successfully flashed with manjaro-arm-flasher) now!
Thank you!

2 Likes

Hi @Crankshaft,

Did you manage to recognize any of the USB 3.0 ports or USB Flash/HDD drives?

Using the latest KDE Plasma image on Opi5-Plus but I am unable to recognize any USB 3.0 Ports drives.

Nope, not working. Hardware acceleration doesn’t work too. But nvme ssd is accessible.

1 Like

You mean VPU hardware acceleration doesn’t work (vpu hardware acceleration did not work on my unit but GPU hardware acceleration works).

Yes, can access the NVMe SSD.

Yes i have rk3588 boards with random wifi chips. I ask looking at these options. Will have to search for its drivers.

Try one from aur and check if that helps.

1 Like

I have the same so called Official Wifi Module from Xulong - RTL8852BE-CG and it does not seem to be recognized. lsmod does not seems to have the module enabled.

As far as I know the driver is “rtw89” but heard that it need some patches to get it to work on Opi5-Plus. The “rtw89” driver is in /lib/firmware/rtw89 but the module is not enabled.

Maybe you have to Include the name of your board in the firmware name. Something like rtl*********.rk3588,orangepi5.bin instead of just .bin
In my board is that way. Look for the error in dmesg and It should tell you what firmware name is looking for.

As far as I can tell, the wifi module/driver is not even loaded or the kernel is not aware it is there.