How to install libua

I have a program that requires liblua

error while loading shared libraries: cannot open shared object file: No such file or directory

How can I install it?

if you open a terminal and use

pamac search liblua

it will show you that it is part of the aur-package of the output. install this packet with the packet-manager (note: you have to activate the option to enable downloads from aur).

When I perform

pamac search liblua

I see

libluasandbox 1.3.0-1 AUR
Generic Lua sandbox for dynamic data analysis

However I have loaded lib32-lua 5.4.4-1 from AUR

But the error message persists when I run the program

i don’t know what application you are involved with BUT a short search at the internet shows that it must be a 32-bit app that was even outdated in the year 2014 !
I don’t know what you are doing but it sounds that you try to ride a dead horse actually. Check for the successor of the application you want to use.

What program?

pacman -Fx

You’ll see that is part of lua52. :wink:

1 Like

Yes - thanks

So why the error message?

As @Olli has pointed out, this is a program that was, as far as I can see, last updated in 2005

Do you have that installed?

What was the return of that command

pacman -Fx

It comes with:

install if you do not have it installed yet

Yes I have that installed, but still get the error (see my response to @Yochanan )

Then, perhaps, an answer to this question could shed light on the issue.

since the needed library is there but “the program” does not see it

it’s impossible to assist since the TO doesn’t give any valuable information. he might think that everyone owes a glass-bowl and can predict future.

1 Like