How to install custom drivers for a printer?

Hey! I’m trying to set up a printer, and I’ve determined it’s model and all[Canon PIXMA TR7520], but I couldn’t find a driver for it in the GUI settings for it in gnome-settings. I’ve supposedly found a Linux driver here, and I’m trying to do it from source as they don’t have any precompiled binaries for Arch-based systems.

That’s that then, I won’t nag anything on – if you know how I can build it or you know if there actually is a driver somewhere :eyes: let me know.

1 Like

Don’t mess up, just install from AUR :arrow_right: AUR (en) - canon-pixma-lt7500-complete

alrightly, I’ll check it out

No dice – do I need to do anything besides the steps mentioned for Printers in the Manjaro Wiki?

1 Like

No, the printer should work after installing the driver. Restart computer for sure.

I’m back now –

Tried that originally actually, didn’t have any dice with it.

Not the solution I was looking for or thinking of, but sending it to my phone to print works for now :sweat_smile:


Looking at that AUR package anyway, people in the description aren’t saying it works with the TR7520)isn’t listed at a compatible printer if I recall), I can’t think of why it it wouldn’t but it isn’t :man_shrugging:
Ubuntu also did something to make it work, as it did on that – just gotta find out what.

What do you mean. I did you install the AUR driver?

I installed the package listed above, don’t know if anything else is needed.

You added the printer through the printer configuration utility?
Screenshot_20200922_114006

Have you checked CUPS admin page at http://localhost:631/?

1 Like

I use GNOME, I don’t know if I have the printer config utility

I did check out the CUPS admin page out as well, the printer never showed up there

Do you have system-config-printer installed?

Yep, just confirmed it’s installed – I’ll have to try a bit later to see if the printer works now for some reason(:man_shrugging: didn’t change anything, but idk), let me know if you know anything else that might help.

Yes, you do. run system-config-printer in the terminal.

Hi. I’ve looked up the link to Canon site. According to it you need

IJ Printer Driver Ver. 5.50 for Linux

File to download is cnijfilter2-source-5.50-1.tar.gz

Arch wiki page on printer drivers refers to cnijfilter2 package in AUR (AUR (en) - cnijfilter2)
Source for that package is cnijfilter2-source-6.00-1.tar.gz (newer version)
So I suggest to install cnijfilter2 from AUR and check if the printer works.
Otherwise you can try cnijfilter2-bin package (older version from Debian package cnijfilter2-5.10_amd64.deb).

3 Likes

cnijfilter2 package did it, thanks a ton! :grin:

Didn’t even know there was a page in the Arch Wiki for that shiz, good to know.

2 Likes

Also, were you just suggesting the drivers that it listed at the top of the Canon section, or did you see my printer model somewhere?

Either way it works now, just curious

1 Like

I’ve looked Canon site link you provided and compared driver download file name from the site with source file name from AUR package.

1 Like

Can’t believe I didn’t think of that :joy: thanks for letting me know

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.