How to install, CUDA compute accelerated ffmpeg

Hello team,

i cannot figure out how to install the ffmpeg with nvidia cuda compite acceleration. pacman absolutely refuses to remove the default ffmpeg and install the accelerated version.

i tried different solitions found on google, but to no avail.

please tell me the proper steps how to upgrade the ffmpeg with the cuda acccelerated version.

hardware equipped with NVidia Quatro P2200, and doing lot of media encoding, so this will speed up my transcodings and encoding. i have lots of ram to manage my projects - 96 bg, dual x5690 xeon cpus.

What version? You should be installing ffmpeg-cuda available in the AUR (Arch User Repository), not blindly following some garbage blog from an author that has never used Arch or Manjaro.

Why not just use NVENC, which is supported in ffmpeg out of the box? It’s newer, faster, and supports both AVC (h264) and HEVC (h265), and yields just as good quality as CUDA.

Your card supports it (just not B-frames in HEVC videos.)

ffmpeg -i original_vid.mp4 -vcodec hevc_nvenc -acodec copy new_vid.mkv

hello, i did not follow some garbage forum. i am vey happy and very grateful with Manjaro forums, i ask my questions here.

i saw the ff-mpeg cuda in arch user repository. then i read the description in the arch user repository and i made my decision, made on the description, being in AUR, what i do, what i need, and what my hardware is.


Did you try this :

sudo pacman -Rdd ffmpeg

And then install whatever version of ffmpeg you need

I don’t think you quite understood. I was referring to…

There are a lot of garbage blogs out there. You never told us what “solutions” you followed or what you even tried.


hello, let me try the command, i will get back to you with the results. thank you for your suggestion.

the suggested command completed successfully, however i get this error during build up of the cuda accelerated version:

ERROR: failed checking for nvcc.

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the mailing list or IRC #ffmpeg on
Include the log file “ffbuild/config.log” produced by configure as this will help
solve the problem.
==> ERROR: A failure occurred in build().

i will try the git, as suggsested, in the meanwhie what is nvcc and how i is installed? Driver? additional package or dependency?

Reboot or log out and log in again and try again to install ffmpeg-cuda.

i do a lot of audio recording and audio editing. i would like to have the CUDA accelerated encoding, decoding and transcoding of audio, i do in the process. It will help me a lot.

oh so obvious, yet so easy to miss, shame on me for not trying

Hello Manjaro team,

I am happy to note, everything works fine now. Audacium also works fine. Finally my Quagro P2200 GPU acceleration is used to my advantage, and cuda cores accelerate audio encoding, decoding and transcoding.

Thank you everyone for your help and assistance. greatly appreciated.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.