How to install a x86 package on ARM?

Specifically I want to install Steam, when I do pacman -S steam it isn’t found. I also tried to use a flatpak but it defaults to aarch64 and won’t find the package. I am trying to run it through an interpreter, so I just need the binaries installed anyway even if they don’t match my native machine’s architecture.

You can’t install and run x86 native on ARM and that command

is a native ARM comand in your case.

What interpreter? Is it capable to install from other repos?
Maybe you take a look at this - read their documentation there, and the box64 is in the Manjaro ARM repos, but you will actually need box86 to try to run Steam trough on your ARM device/system.

I still need the steam x86 binaries before running it. I figure there should be a way to still install the x86 binaries from pacman? Pacman doesn’t run steam so it should still work for installing it. For example on Armbian I can do apt install ./steam.deb and it will install the x86 executables.

Likely pacman does control the package arch=()/$CARCH before installing, but haven’t tried this

pacman will try to install the dependencies, even if you can skip this, the lib32- dependencies doesn’t exit at all