How to get Smooth Performance with Nvidia?

Hey folks Manjaro newbie here. Been using Ubuntu a long time but these days it’s got stale. So time to try this. So far I’m digging the experience. Stability is good so far for me (touch wood).

On Ubuntu I had it running pretty smooth using Nvidia Performance mode and I was able to make tweaks in nvidia-settings. On Manjaro those options aren’t available due to hybrid mode I guess (but also the option to switch modes isn’t available).

inxi --admin --verbosity=7 --filter --no-host --width            ✔ 
  Kernel: 5.10.68-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64 
  root=UUID=fd7209c8-38d6-4ae4-9306-da051cd67194 rw rootflags=subvol=@ quiet 
  splash apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 065C71 v: A00 serial: <filter> UEFI: Dell v: 1.13.1 
  date: 12/18/2020 
  ID-1: BAT0 charge: 71.1 Wh (100.0%) condition: 71.1/74.0 Wh (96.1%) 
  volts: 12.3 min: 11.1 model: Samsung SDI DELL 0GFJ679 type: Li-ion 
  serial: <filter> status: Full 
  RAM: total: 15.5 GiB used: 4.56 GiB (29.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  cache: L2: 6 MiB bogomips: 44817 
  Speed: 2228 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2228 2: 1421 
  3: 1373 4: 1181 5: 1372 6: 1916 7: 1996 8: 1419 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c8c class-ID: 0300 
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-12:7 chip-ID: 1bcf:28c1 class-ID: 0e02 
  Display: x11 server: 1.20.13 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.2 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403 
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.68-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 
  bus-ID: 03:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-4:5 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Device-1: luks-721307aa-6da4-4db0-80a6-f0736f3e5621 maj-min: 254:0 
  type: LUKS dm: dm-0 size: 73.66 GiB 
  p-1: sda7 maj-min: 8:7 size: 73.66 GiB 
  Device-2: luks-5f2ba54f-9809-4737-84e0-17acea13f6b3 maj-min: 254:1 
  type: LUKS dm: dm-1 size: 931.51 GiB 
  p-1: sdb1 maj-min: 8:17 size: 931.51 GiB 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 31 class-ID: 0104 
  Local Storage: total: 1.94 TiB used: 648.15 GiB (32.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD PM871b M.2 2280 128GB 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 2D0Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01ABD100 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: 3D scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital 
  model: WD10EAVS-00D7B1 size: 931.51 GiB block-size: physical: 512 B 
  logical: 512 B type: N/A serial: <filter> rev: 1.75 scheme: MBR 
  Message: No optical or floppy data found. 
  System Temperatures: cpu: 52.0 C mobo: 41.0 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 367 Uptime: 11h 6m wakeups: 1 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: N/A Packages: 1298 pacman: 1292 lib: 430 
  flatpak: 6 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06
xrandr                                                           ✔ 

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.02 +  60.01*   59.97    59.96    59.93    48.03  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080     60.00*+  59.94    50.00    23.98    60.05    60.00    50.04  

TLDR; anyway, any pointers as to how I can get smooth performance on Gnome and not this jerky experience I’ve been having? I’m happy to use dedicated Nvidia driver if he hybrid can’t do Gnome smoothly and I’ll consider Open Source Intel with Wayland too as a short-term fix.



In order to get an objective reply, please make sure you read and follow this How to provide good information and then share that information here.

1 Like

If you’re looking for the Ubuntu MATE or Mint experience with Manjaro, you’ll need its proprietary hybrid driver combined with optimus-manager.

1 Like

Thanks yeah I found this other post and he’s kind of having the same issue as me. So I’m currently running through the process of setting up Optimus.

Have installed optimus-manager, and a QT Gnome extension for switching, and entered the following:
systemctl enable optimus-manager.service

So far none of the config is really working except that on reboot it was running smoothly with Wayland and X. Looks great. Sadly I can’t get multi-monitor (Wayland or X) nor the most out of my graphics card for games yet.

It looks like the next task is replacing libgm with gdm-prime? I have the file but could you tell me how to do that?

Sorry, I don’t use GNOME and don’t know much about GDM except that Wayland needs to be disabled to get optimus-manager working. It definitely seem more complex with GNOME than with other DEs.

If you use GNOME then yes you need to install gdm-prime from the AUR

pamac build gdm-prime

then when you reboot,make sure to login in X and not Wayland,then you can now switch cards,if you want nvidia is just

optimus-manager --switch nvidia
1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

That got me further but I then was getting this notification at login/unlock screen:
You're not using GDM-Prime.

And this problem seemed to explain what happened when I tried to enable NVidia yesterday. I had only a cursor and a dark grey screen. However, today I realised it may just be that the login prompt was coming up on my TV–which is my secondary display–rather than my monitor (as sometimes happens when I install a new display driver) and bingo that was it! Yay!

No wonder the logs weren’t giving me any clues. :smiley:

So now I am running in prime-nvidia mode and the desktop is smooth as well as games and with secondary monitor support. Haven’t fully tested out the other modes yet but this appears to be at least as good as I had on Ubuntu.

Thanks @XRaTiX and @Fabby. Also @ralm and @bogdancovaciu.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.