How to get SDDM to play nice with XFCE?

So I’ve tried to use SDDM with XFCE, but it doesn’t seem to want to work properly, and I’m not savvy enough to know what’s the underlying reason.
I removed lightdm and installed SDDM, so far so good.
The problem is that when I cold boot the system, I get greeted with the TTY1 login screen. Upon logging in with my user, I get the following errors:

xset: unable to open display ""
xset: unable to open display ""

After trying to reset SDDM through systemd # systemd reset sddm.service; the greeter shows up as expected.

After some jiggery-pokery around I managed to fix this by telling SDDM to start on TTY7 instead of 1.

And now the greeter shows up automatically as it should (well, on one of my machines, the other still doesn’t work as expected), but I’m still having issues with SDDM once the screen gets locked or if I suspend the system and then resume.

It always shows a blank screen (on TTY7), and the only option for me is to restart the service like above, which causes my whole XFCE session to end, so I have to start with everything from scratch.
Also tried to launch the greeter manually from TTY1, but would throw a QT error (see below)

I’ve seen this issue reported for folks that are using NVidia or AMD video cards (or a combo of Intel and one of those), however I’m only using Intel IGP.

Tried various things, all which did not help at all.

Here are some logs that might be useful, if not, feel free to ask me for what’s relevant:

Loading greeter manually:

[01:17:25.585] (II) GREETER: High-DPI autoscaling not Enabled
[01:17:25.589] (WW) GREETER: could not connect to display 
[01:17:25.589] (II) GREETER: Could not load the Qt platform plugin "xcb" in "" even though it was found.
[01:17:25.589] (EE) GREETER: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.



inxi (switched back to lightdm for the time being, ignore that section)

sddm is for KDE
lightdm ( better lightdm-greeter ) is for Xfce

you now have two display managers installed
and likely both are active

as the saying goes:
there can only be one …

deactivate one of the two
make one of the two active
but don’t start both

systemctl status sddm.service
systemctl status lightdm.service

systemctl enable sddm.service
systemctl disable lightdm.service

or the other way around
to use sddm

ahh - you removed lightdm
sorry for having missed what you clearly stated!
just enable sddm.service then
so it starts automatically

Have you actually enabled the SDDM service, so it starts automatically?

What locker did you use before removing lightdm? AFAIK Xfce now uses xfce4-screensaver, but light-locker was quite common some time ago.

The service is enabled automatically after installing it. I checked it by enabling it with systemctl, that’s how I know.

Yes I did (or rather pacman did it)

I was/am using light-locker AFAIK. I know a long time ago I had issues with xfce4-screensaver so I switched to light-locker a few years ago.

I know… but I decided to switch to SDDM because, reasons. Basically lightdm doesn’t do what I want it to do, so I thought I should use a different display manager.

then, at least, abandon light-locker as well

From what I have seen here
I’m still not sure what the problem is
with sddm
instead of lightdm
as a display manager

is this still about redshift?
(as your link to the other thread suggests)

This will redirect you to VT8 (assuming that your open session was on VT7 and is now kept safe by light-locker) and present LightDM’s greeter for unlocking your session again. On suspend/resume light-locker will lock the active session and redirect to the LightDM’s greeter for unlocking the session again.
GitHub - the-cavalry/light-locker: A simple session-locker for lightdm

light-locker does not require the lightdm package, so it should still be installed and configured as the current locker – since you need to explicitly set Xfce to use it. Yet it may still fail to start because it still needs it.
So either install lightdm and its greeter back, change Xfce’s configuration to lock to SDDM, or outright use another locker/screensaver.

Yes, Redshift is one quirky behaviour that I did not have while using Cinnamon DE in Manjaro (IIRC that also uses lightdm, right?). Besides it I also have issues with configuring lightdm, resuming from suspend with monitor set to stand-by (it turns itself off), and configuring how the greeter looks (none of the configuration pertaining to that gets applied)

Would you have any suggestions as to how to do that?

Passed by to remind you that SDDM has no connection with Lock Screen neither in KDE Plasma, so for XFCE you will definitely need another Lock Screen.

By “Lock Screen” you’re referring to lightlocker?

Yes, light-locker package is a Lock Screen aka simple session locker but mostly plays nice with LightDM.

Alright. Removed light-locker, and installed xfce4-screensaver. Set it up so that it locks after the blank screensaver.
It doesn’t seem to lock, but since right now that’s not an major issue for me, I’ll leave it as such.
If you guys have any other suggestions what I could try, I’m all ears.

Thanks for the help everyone!

Just checking: how did you do so?

Going the the Screensaver settings under the Settings Manager:

As a side effect of switching to xfce4-screensaver, it now kicks in the screensaver when I’m watching longer videos on YouTube :man_facepalming:

Since setting up light-locker requires an explicit configuration as linked above, setting up something else requires you to edit or, in your case, remove that configuration.