How to get maliit-keyboard show up?

Hi! I just installed Manjaro Plasma edition on a Dell Venue 11 Pro tablet.
It runs much smoother and requires far less RAM as W10 but it is not really usable as there is no on screen keyboard.
I installed maliit-keyboard but it doesn’t show up anywhere.
I found some pages describing it’s installation but there it is mentioned that I should enable it in System Settings - Input Devices.
I rebooted after the installation but I can’t find it anywhere. (It is installed correctly tough.)
Can someone tell me how to set it up properly? Thanks.

I don’t know about the mentioned keyboard - I would think the qt5-virtualkeyboard package would be better.

1 Like
  1. You should use Wayland.

  2. Select it in Settings

1 Like

@linux-aarhus In the search results I found, it was explicitly advised to use Maliit with Plasma but I will take a look at qt5-virtualkeyboard as well. Thanks for the suggestion.


  1. How do I make sure that I use Wayland?
  2. There is no Virtual Keyboard entry in the Input Devices section.
1 Like

It tells me X11. How do I switch to Wayland?

EDIT: qt5-virtualkeyboard is already installed. But it doesn’t show up either…

logout and check the login-page. there should be a menu at the left-bottom of the screen where you can select between x11 and wayland.

1 Like

Thanks! We are halfway there. :laughing:
Can I make Wayland the default?
I set up autologin after a reboot and X11 is taken as default.
When I log out and set Wayland on the login screen there is still no virtual keyboard (for the password).
After I typed my password (via bluetooth keyboard) and logged in, Maliit is there but behaves somewhat strange: it’s icon is missing from the task-bar but if I click on the empty space on the bar, the virtual keyboard pops up. So it is kind of working. It is also available in the device settings menu.

it is the default now. it will only change if you set it back to x11 at login (vice-versa). you don’t need to change it everytime.

can you try a reboot, login with wayland. any changes ?

okay, please read the wiki-link i post. ask if you need some help. you’ll need to edit the sddm-config file as described in the post.


CompositorCommand=kwin_wayland --drm --no-lockscreen --no-global-shortcuts --locale1 --inputmethod maliit-keyboard

I checked that directory and there is no 10-wayland.conf in it.
There is a virtualkeyboard.conf in there and it has this line:

  1. Should I uninstall qt5-virtualkeyboard?
  2. Should I create the 10-wayland.conf file or should there normally be one?

never used one but i would do this too. create the conf file and paste the content of the wiki inside. reboot and check if this might already be enough to solve the problem.

I created the file with the General and Wayland sections, but the autologin ignores it.
I can’t find the menu entry in the settings where I can turn off autologin.
Under which entry is it?

from the wiki-post

SDDM now displays a button in lower-left corner of login screen to open the virtual keyboard. 

is there such a button at login-screen ?

I only use onscreen keyboards and Onboard is my absolute favorite, ram usage is about 80MB.

Not after a reboot as I have autologin on.
This case it logs in with X11 automatically and ignores Wayland.
Before I created the 10-wayland.conf file, I had to log off and then I could select the virtual keyboard (lower left corner) on the login screen.
Now, when I try to log off, the system hangs with a black screen.
As if, the wayland conf file would have made some braking changes.
I checked it’s content but it is correct.

With KDE Plasma?

sure ? once you’ve choosen wayland at login, then it stays on wayland. anything else is not the working behaviour of kde.

Yes, I checked with the echo command. It’s X11

EDIT: it is also strange, that I’m not able to log out now. (No longer landing on the log-in screen after logging off)

I’m tired, will continue tomorrow. Many thanks for the help!
I will post when I have tested more tomorrow…



create this config file. it is described in the wiki-post i linked.

That was already there. I think it was created as I installed Manjaro. As I understand the wiki, it is only for the login screen.