How to get Intel HD + Nvidia 740M to work

Did anybody got Nvidia 740M to work?
If so, what is the path to choose? I read about bumblebee, optimus prime and others.

MHWD installs 390xx bumblebee drivers. I tried open source and proprietary in MHWD GUI but my Nvidia card is not detected. Applications complain about missing openCL.

inxi -G
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Device-2: NVIDIA GK208M GeForce GT 740M driver: N/A
Display: wayland server: Xorg 1.20.13 driver: loaded: vesa
resolution: missing: xdpyinfo
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.2.3

I understand the blame is to be found at Nvidia. Now I’m at the point, is it even possible to get it to work. Thanks in advance.

Hey!
Did you get this to work eventually?
I have the 740M/Intel combo too (Asus N56VB laptop).

Until recently I just forced the Nvidia driver version 490, completely bypassing the Intel GPU.
This was kind of a hassle to setup, and has some downsides. For example, video decoding is apparently handled by the Intel GPU, so VLC never played any videos for me. It also always enables the Nvidia GPU, increasing power usage.
On the plus side, I never have any hassle switching, and gaming worked well. Or as well as it can on a 8 year old laptop anyway. :upside_down_face:

However, with the latest 2021-11-19 stable release, this setup got messed up as the Nvidia driver updated to the latest version, 495, in which support for Kepler GPUs was dropped. And that includes the 740M, unfortunately.
My laptop would not boot and I’m currently writing this using the nouveau driver.
This works fine for work, browsing the internet, running some VMs, etc. But the gaming experience is unfortunately lacking, and I’m contemplating what next to do.

Hi Deinara, I did not get it to work after giving it considerable time and my best linux-fu :slight_smile:

I have RTX3060 and the MHWD installed the card(hybrid intel-nvidia-prime) but it wouldn’t switch it on. The bbswitch(bumblebee) worked well only on linux Mint from my own experience. I had to install Optimus Manager/QT to make the nVidia card work for playing games.