How to fix my system when it is freezing randomly?


Please, my desktop computer is freezing randomly over time. I only use a web browser (Brave) and a text editor (Sublime Text) for coding.

Here are the things that I have tried so far to fix this issue:

  1. I have tried to format my system.
  2. I have tried to change my hard drive to a fast SSD.
  3. I have changed the motherboard and upgraded my RAM to DDR4 (I was using DDR2).

Note 1: It is good to note that my computer is freezing almost instantly without getting any time to check any memory consumption tool. My screen freezes along with my mouse and keyboard. No key will function anymore. Shortcuts to access the shell or to log out or to so anything won’t work anymore when the system freezes. I have tried every single key combination on my keyboard and went as far as creating custom shortcuts for accessing the shell or shutting down but nothing would work out. As if my keyboard is not connected anymore.

Note 2: There is no time limit for this freeze (or memory leak). It might happen after 1 hour of work or after 10 hours. Some days pass as well without it happening at all. I couldn’t manage as well to pin-point a specific event to this freezing event.

Before posting this thread, I decided to set a limit by editing the file at: /etc/security/limits.conf

I have added the following lines:

* soft  core  0
* hard core unlimited

* hard nproc 1024
root hard nproc 65536

* hard nice -19
root hard nice -20

* soft priority 0
* hard memlock 1000000
* hard nofile 8192

Note: I am not an expert with these settings and I am not even sure if limiting my system in such a way would help or not.

My System Specification:

- Operating System: Manjaro Linux
- KDE Plasma Version: 5.20.5
- KDE Frameworks Version: 5.78.0
- Qt Version: 5.15.2
- Kernel Version: 5.10.7-3-MANJARO
- OS Type: 64-bit
- Processors: 4 Ă— AMD Ryzen 3 2200G with Radeon Vega Graphics
- Memory: 7.7 GiB of RAM
- Graphics Processor: GeForce GTX 1050 Ti/PCIe/SSE2

Any ideas, tips, or solutions will be much appreciated! Thank you very much for taking the time to read my question.


  • Firmware version
  • Kernel arguments
  • Disable any customization like extensions, widgets, themes …
  • Have you any bittorrent clients running?
  • Have you tried another browser?

I would expect the freeze to occur no matter the desktop used?

Have you verified by using e.g. LXQt or XFCE - try running from a live system - you can modify GRUB to boot an ISO from your disk.

Thank you for your reply and suggestions.

  • I haven’t played with the firmware version or the kernel arguments. I kept everything in its default version.
  • I have everything disabled already including all extensions and widgets. I use the default theme that comes with Manjaro without any modifications.
  • I don’t use bittorrent or torrent clients.
  • I have tried all the three popular browsers: Firefox, Chrome, and Brave.

I haven’t though verified the error using a different desktop environment because I like the KDE and I have been using it for over 5 years. I can’t give up on KDE since I am used to it. I prefer to find a way to identify the issue instead. I have no problem changing any part of my computer if changing a part would solve the issue.

I do appreciate your ideas and suggestions. Thank you once again!

I understand - I didn’t say you should :slight_smile: replace KDE - not even install - it can be done using GRUB - the idea was to isolate if it was something KDE related or hardware related - I mean if the issue persist across environments - then it is hardware related.

Another idea is the kernel have you tried the LTS kernel? Which is closely related to kernel arguments.

Some AMD systems sometimes requires special arguments - the arguments required can even differ between implementations by different main-board vendors.

My last idea is system overheating - faulty heat sensors?

From another topic - where the member’s inxi showed no swap.

Do you have swap enabled - even a small swap is better than none.

Thank you for your reply and clarification.

Concerning your question, I have just typed the command:


Here is the result:

/dev/nvme0n1p3 partition 8.8G   0B   -2

I always set a swap partition when installing Manjaro.

I will try a different desktop environment and I will also try to switch to an LTS kernel instead of the latest one. I will keep this post open for a few days until I collect more information based on your suggestions.

I doubt it is a system overheating issue since restarting the system instantly resolves the problem for many hours to come. Perhaps the heat senors are at fault but that is not easy for me to debug. I have tried already to change the motherboard, CPU, and RAM. The only thing that I haven’t changed yet is the graphic card (which is a bit old). I am thinking of changing my graphic card temporary and test the system out as well.

I am using the same kernel, settings, and apps on my laptop and two other computers at home without experiencing this problem. They have different parts than what I have on this desktop computer though. Maybe my hardware parts are conflicting with the newest kernel as you said. Or it might be from KDE.

I have had this issue in the past, several years back, and the problem was software related. A browser addon was causing it. Sadly, it is not the case this time since it is the first thing I tried and suspected when debugging this problem.

I will try to collect more information and update this thread. Thank you once again!

1 Like