How to enable Snap support? There is only Flatpak switch available (but both are said to be there by default)

So, just the topic. Can’t find the switch to enable snapd.

Also as i switched the Flatpak support on, i still can’t install flatpaks from Flathub: when i click on install it download a href file, and when clicking THAT it opens “Add / Remove software” but the window is empty?

snap is another packet thingi


Ok i’ll read that in a minute but i’m thinking is my installation broken or missing things? Why is there only flatpak switch and no snap though both should be supported by default?

Ok i read that docs but it is about that same flatpak (which i enabled already and though it wont work it seemed to get enabled).

Where is the snap switch i’m meaning?

Did you install libpamac-snap-plugin, you will only see the switch after that is installed.

Oh ok so i will get this from the software center? And THEN the switch appears? Let me try then thanks.

The docs link above specify that.

Found and installed the libpamac-snap-plugin but stil the switch to enable snap does not appear? Or do i need to restart the system?

You dont need a system restart but did you try to close pamac and reopen it?

Now i did (the system didn’t say anything about to restart pamac, maybe something like that could be added?) AND the switch appeared! Nice.

But as i earlier enabled flatpak, when i click to search flatpaks in pamac: for example the ProtonUp does not appear to search even though i know it is in Flathub. Now what?

Sure I can add that to documentation, as for Protonup, open a issue on the pamac repo on gitlab.
and dont forget to mark you post as solved.

Oh, i was kicked out suddenly from Manjaro Gitlab for no apparent reason - this was earlier queried on Reddit but i cant post links here so.

But here it is from there:

An email:

"You will not be able to:

Access Git repositories or the API.
Receive any notifications from GitLab.
Use slash commands.

To reactivate your account, sign in to GitLab.

Please contact your GitLab administrator if you think this is an error."

This happened after this issue was closed: https://gitlab

Also i cannot not even sign in (as instructed to reactivate)…

Here: https://www.reddit. com/r/ManjaroLinux/comments/10719we/manjaro_gitlab_suddenly_your_account_has_been/

I can see protonup on my end so maybe try to refresh your database.

Yes the refresh helped and it appeared! (the system yet again didn’t indicate any need for a refresh, maybe add that to pamac in future too?) these little details seem to mean a world and many can’t know (including me) automatically what is still required to do.

A little hint after installing flatpak / snap capability would be good (restart pamac and- or refresh).

Thanks for patience.

All those things would make a difference, but is always up to the software developer if he wants to implement them or even has the time to do so.

Oh i see, so pamac is not a Manjaro entity but adopted there. What about this issue:

Yes Pamac is a manjaro tool.

dont post on reddit, developers dont read reddit, your account was most likeley removed because it was inactive, there is a limit on accounts nunbers and a cost associated with it, if you have any question about it open a new post in questions section as this subject has nothing to do with corrent post and this subject is already solved.