How to enable dark mode for GTK apps?

I am using Manjaro Gnome edition. I am using default Matcha Dark theme. But some apps doesn’t enable dark mode. Like vlc, smplayer. tried changing theme… but doesn’t work. Any help?

#################### inxi -Fxzc0 ########################

    System:    Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: GNOME 3.36.6 
               Distro: Manjaro Linux 
    Machine:   Type: Laptop System: ASUSTeK product: X550JK v: 1.0 serial: <filter> 
               Mobo: ASUSTeK model: X550JK v: 1.0 serial: <filter> UEFI: American Megatrends 
               v: X550JK.304 date: 04/16/2019 
    Battery:   ID-1: BAT0 charge: 11.0 Wh condition: 11.2/32.6 Wh (35%) model: ASUSTeK X550A30 
               status: Not charging 
    CPU:       Topology: Dual Core model: Intel Core i5-4200H bits: 64 type: MT MCP arch: Haswell 
               rev: 3 L2 cache: 3072 KiB 
               flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22356 
               Speed: 3179 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 3151 2: 3150 3: 3150 
               4: 3148 
    Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: ASUSTeK driver: i915 
               v: kernel bus ID: 00:02.0 
               Device-2: NVIDIA GM107M [GeForce GTX 850M] vendor: ASUSTeK driver: nvidia v: 450.66 
               bus ID: 01:00.0 
               Device-3: Realtek USB Camera type: USB driver: uvcvideo bus ID: 1-7:5 
               Display: x11 server: 1.20.8 driver: modesetting,nvidia 
               resolution: <xdpyinfo missing> 
               OpenGL: renderer: GeForce GTX 850M/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes 
    Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel 
               v: kernel bus ID: 00:03.0 
               Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
               driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
               Sound Server: ALSA v: k5.8.6-1-MANJARO 
    Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave 
               driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
               IF: wlp3s0 state: up mac: <filter> 
               Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
               driver: r8169 v: kernel port: d000 bus ID: 04:00.1 
               IF: enp4s0f1 state: up speed: 100 Mbps duplex: full mac: <filter> 
               IF-ID-1: Wireguard-WARP state: unknown speed: N/A duplex: N/A mac: N/A 
    Drives:    Local Storage: total: 1.02 TiB used: 65.19 GiB (6.2%) 
               ID-1: /dev/sda vendor: Western Digital model: WDS120G2G0A-00JH30 size: 111.80 GiB 
               ID-2: /dev/sdb vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
    Partition: ID-1: / size: 109.25 GiB used: 14.80 GiB (13.5%) fs: ext4 dev: /dev/sda2 
    Swap:      ID-1: swap-1 type: file size: 4.00 GiB used: 0 KiB (0.0%) file: /swapfile 
    Sensors:   System Temperatures: cpu: 97.0 C mobo: N/A gpu: nvidia temp: 74 C 
               Fan Speeds (RPM): cpu: 25500 
    Info:      Processes: 311 Uptime: 2h 29m Memory: 7.66 GiB used: 3.40 GiB (44.3%) Init: systemd 
               Compilers: gcc: 10.2.0 Packages: 1244 Client: shell wrapper v: 5.0.18-release 
               inxi: 3.1.05

those aren’t gtk apps. Open kvantum and set their theme there.


Qt-based applications have to be configured separately, through qt5ct, and for more fancy results, in combination with a kvantum theme. :wink:

1 Like

thnx. it worked.

That’s actually not used anymore on GNOME. QGnomePlatform has replaced it. Looks better and no need for fiddling. Kvantum Manager is optional, but is still used to override the Qt Style.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.