How to edit mimeapps.list to get Nautilus to open up Files/Drives vs SMPlayer?

I have never got anywhere in the Settings/Applications area, however using previous topics on this forum, have opened mimeapps and changed:
inode/directory=smplayer.desktop
to
inode/directory=nautilus (or nautilus.desktop).

With or without .desktop, now the SMPlayer no longer opens up but rather a Terminal File Manager not the usual Nautilus GUI.

This doesn’t happen when I have opened up and am in Nautilus, only when am accessing via a link to a Place from other programs, for example in PCloud where it says Open Drive, SMPlayer comes up instead of the PCloud Drive in Nautilus, or in the Places Extension on Panel, when I click on any of the listed drives or bookmarked directories which are displayed, SMPlayer comes up (used to come up, now it’s the Terminal File Manager).

Please advise.

The correct entry in the mimeapps.list file would be:

inode/directory=org.gnome.Nautilus.desktop

Make the change in the file and give it another try.

2 Likes

Thank you VERY much!

For the sake of learning, I am wondering:
a) how did this happen, is it something the SMPlayer repository has written in wrong or what?
b) how do you find out what the issue is, or how to troubleshoot? And how do you know the right thing to input? Is this just the result of years of digging around in the bowels of the systems (like the old Windows regedit registry realm) and learning your way around. Even after a decade with Linux, not being a very good Terminal user etc. I still find things like this a huge mystery. Have I missed some basic steps somewhere, or is it entirely normal and OK that I depend on the kindness of strangers like yourself to provide the solutions.

1 Like

You’re welcome!

Regarding your questions:

a) I’ve seen this happening often, not quite sure why it happens - it could be a false user choice or an issue in the way the system reads the shared MIME info database.
In every case, now that you have set the entry for the inode/directory MIME type in the mimeapps.list file, you won’t have that problem again in the future.

b) The .desktop files for all applications in your system are stored in the directory /usr/share/applications/ (some of them might be in the ~/.local/share/applications/ directory).
To find the right .desktop file, you can search in that directory using something like this for example in a terminal window:

ls -l /usr/share/applications/ | grep -i "nautilus"

(where nautilus is the search term).

The result can be used in the mimeapps.list file or in any other file that requires the exact name of the .desktop file of Nautilus.

1 Like

Thanks.

1 Like

Well, a couple of days later and the problem returned. Smplayer had been put back into the line so it seems this is something the system is doing so, practically speaking, I’ll just have to live with it or stop using SMplayer which I like because their subtitles interface is far better than any other I’ve used.

Also, my Terminal is flashing and 100% transparent making it unusable except in a virgin workspace and have no idea how to fix it. Pity. For a while my system was running perfect with no issues. I guess this is the rolling release experience, eh?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.