How to downgrade? No Packages available


Due to a bug in systemd I need do downgrade to 247.4-2.
With “downgrade” as named in the manjaro wiki it seems not possible:

wolf@wolf-desktop:~$ DOWNGRADE_FROM_ALA=1
wolf@wolf-desktop:~$ echo $[DOWNGRADE_FROM_ALA]
wolf@wolf-desktop:~$ sudo downgrade systemd

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See Downgrading packages - Manjaro Linux for more details.

Lade Pakete…
Warnung: systemd-248.3-3 ist aktuell – Reinstalliere
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…

Pakete (1) systemd-248.3-3

Gesamtgröße der installierten Pakete: 25,73 MiB
Größendifferenz der Aktualisierung: 0,00 MiB

:: Installation fortsetzen? [J/n] n

So how do I get to this version?

The disabling of DOWNGRADE_FROM_ALA on stable branch seems to be intentional, see
close-ala-in-stable.patch · master · Packages / Community / downgrade · GitLab.

You can still use old packages residing in your package cache (/var/cache/pacman/pkg).
Mind you: if you do downgrade, remember to downgrade all four systemd packages together (systemd, systemd-libs, lib32-systemd, systemd-sysvcompat).

Switching to another branch (hint: testing) also enables DOWNGRADE_FROM_ALA functionality…


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I don’t have any package in my cache. So this is NO solution.
The seconds proposal switching to “testing” branch is also no solution, because then I will get a lot of updates I don’t want on my productive system.

So is there really no chance do downgrad a package in Manjaro if you donÄt have it in your personal pkg cache? Really? This looks like a problem by design???!!!

Imho the manjaro patch is somewhat broken.

I think the intention was that with setting the environment variable DOWNGRADE_FROM_ALA=1, downgrade should allow ALA even on stable (which does not work).

Anyways, you could grab the original downgrade as a temporary workaround:

chmod +x downgrade
sudo ./downgrade *package-name*
1 Like

Please keep in mind that Manjaro build some packages by its own.

The downgrade from a server works IMHO only for package that are directly imported from Arch. If a package is build by Manjaro developer, it needs to be in your cache.

If your really need a special version of a core system package, downgrade is never a good solution or workaround. In such cases, get the sources from and build it against the current set of packages yourself.

1 Like

Created an issue…

Thx for creating the bugg report. I got topday a update of “downgrade” to version 10.1.0.
But there is still the same bug.


sudo DOWNGRADE_FROM_ALA=1 downgrade *package-name*

Afaik it got already pushed to all branches.

Okay, thx. I just used the wrong command/syntax. There is no example in the wiki.
I always typed:

wolf@wolf-desktop:~$ DOWNGRADE_FROM_ALA=1
wolf@wolf-desktop:~$ echo $[DOWNGRADE_FROM_ALA]
wolf@wolf-desktop:~$ sudo downgrade systemd

Just to explain why your commands did not work: you’re setting the environment variable in your local environment of your current user but execute the command with sudo - which wasn’t instructed to keep the current environment - therefor the variable is not visible for the command.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.