HOW to Downgrade CUDA version on Manjaro?

Blender use CUDA version 10.1 to 11.4.
In manjaro installed CUDA version 12.1
so Blender failed to render using CUDA cycle.

How to downgrade it?

Are you fully up to date?
What version of blender?

CUDA is 12.x version on all branches


Blender is 3.5 in stable (to be removed from community and moved to extra) and 3.6 in testing and unstable


Even the downloaded version 3.3.6 from the blender website, or version 4 can render with the CUDA version i have installed.

Please show the error you get. Are you sure that your Nvidia Geforce GT 730 didn’t run out of memory because the scene you try to render?

One last chance: install package downgrade" (in extra) and use it (sudo required):
sudo downgrade cuda

I don’t think that’s a good solution. Cuda and the Nvidia drivers are heavily connected. This might not work.

this the error… happen after update sistem manjaro and blender version…before it i can use render cuda cycle

CUDA version 12.1 detected, build may succeed but only CUDA 10.1 to 11.4 are officially supported.
Compiling CUDA kernel ...
"nvcc" -arch=sm_35 --cubin "/usr/share/blender/3.5/scripts/addons/cycles/source/kernel/device/cuda/" -o "/home/ulfan/.cache/cycles/kernels/cycles_kernel_sm_35_A055A82CFC11073845226D9705D2330F.cubin" -m64 --ptxas-options="-v" --use_fast_math -DNVCC -I"/usr/share/blender/3.5/scripts/addons/cycles/source"
nvcc fatal   : Value 'sm_35' is not defined for option 'gpu-architecture'
Failed to execute compilation command, see console for details.

Refer to the Cycles GPU rendering documentation for possible solutions:

This is My system

nvidia-smi                                                                                                                                                                   ✔ 
Sat Jul  8 17:26:00 2023       
| NVIDIA-SMI 470.182.03   Driver Version: 470.182.03   CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 N/A |                  N/A |
| N/A   43C    P0    N/A /  N/A |   1182MiB /  1999MiB |     N/A      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|  No running processes found                                                 |

nvcc --version                                                                                                                                                             1 ✘ 
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2023 NVIDIA Corporation
Built on Mon_Apr__3_17:16:06_PDT_2023
Cuda compilation tools, release 12.1, V12.1.105
Build cuda_12.1.r12.1/compiler.32688072_0

This looks like your GPU is too old for Cuda 12.

You might need to install a different version (legacy?) of the drivers and then downgrade cuda.

You try the cuda-11 version from the AUR AUR (en) - cuda11.1

i am not programmer and dont understand how to downgrade. is there tutorial step by step how to do it?

install package “downgrade” (in extra) and use it (sudo required):
sudo downgrade cuda
self explaining (double-click on the wanted entry …
The AUR-Package:
just install, the package from the repo will be un-installed automaticly…

 sudo downgrade cuda                                                                                                                                                          ✔ 

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1.
See  for more details.

No results found
Unable to downgrade cuda

This sounds more like an issue related to gcc … CUDA is built against gcc12 because is the only one supported, so either you are missing that package, and due to the pending merge of packages from community into extra you might have something off, because gcc is 13 officially now in repository; and building CUDA11 or 10 from AUR against it will take ages, i do not recommend that … or you could try to see if by creating a symlink like this will sort things out when you next start blender.
sudo ln -s /usr/bin/gcc-12 /opt/cuda/bin/gcc

1 Like

My PC using Nvidia GT 730 that not support CUDA 12. only support max CUDA 11.4 version. because it is old Graphic Card Type.

Then the best approach is downgrade so you might want to switch branches to either testing or unstable.

That’s the reason for the error message. See here: CUDA 12.2 Release Notes

Dropped support for sm_35

Please read the error message, it tells you exactly what to do:

sudo env DOWNGRADE_FROM_ALA=1 downgrade cuda

thanks all. Now Blender can utilize CUDA for Render Cycles.
First, I remove CUDA version 12: Pacman -R Cuda. Then, I install CUDA version 11 using YAY.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.