How to disable Zswap?

Hy, I recently installed Manjaro linux, It’s great OS much smoother than win11, but games were crashing , found out there was no swap memory created by default,
so I created one manually, and crashing problem solved at some extend, now I wanna try Zram, but for that to work efficiently, Zswap need’s to be disabled.

I changed changed grub conf: /etc/default/grub and added



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash udev.log_priority=3 zswap.disable=1

save and sudo update-grub

after booting again: zgrep CONFIG_ZSWAP_DEFAULT_ON /proc/config.gz
still returns: CONFIG_ZSWAP_DEFAULT_ON=y

cat /sys/module/zswap/parameters/enabled
returns: Y

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.6.26-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5500U with Radeon Graphics
Memory: 7.1 GiB of RAM

Where did you get that from?


This doesn’t matter. You can’t change kernel options unless you recompile the kernel.

1 Like

This should be zswap.enabled=0

(oh, darn, this would be in the link from @anon51566685 posted at same time. :horse_racing:)


Thanks guys the zswap.enabled=0 worked, I read that arch wiki before but didn’t understood their language as I’m newbie, so I asked chatgpt and it explained those steps much easier and gave that zswap.disable=1 wrong command.

I hope you learnt that that is a Bad IdeaTM.


From that wiki:

To disable zswap permanently, add zswap.enabled=0 to your kernel parameters.

How can it be any more understandable than this?

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.