How to disable two finger horizontal back and forward gesture?

Since a recent system update horizontal scrolling with two fingers on my touchpad now triggers back and forward actions.
it’s very anoying since scrolling vertically on a web page will sometimes navigate through history unintentionally. I’m using libinput gestures with three fingers for this feature and i would really like to get rid of this two fingers gesture.
any clue ?
My system :

Cinnamon : 5.4.2
Kernel : 5.18.6-1-MANJARO
libinput : 1.21.0-1
libinput-gestures : 2.73-1

Thank you ! :slight_smile:

You need to go under System settings → Input devices → Touchpad and the last option will be “Disable horizontal scrolling”: check it for disabling it

thank you for your answer, unfortunately there is no such options :

: (

I figured out that this unwanted features is related to my xbindkeys settings that I’m using for my logitech mouse :

#back button 6
"xdotool key Alt+Left"

#forward button 7
"xdotool key Alt+Right"

#Desktop left button 9
"xdotool key Super+w"
#Desktop right button 8
"xdotool key Super+c"

I now need to find how to keep those settings for my mouse without altering the trackpad’s functionnalities

I managed to disable “Button Horiz Wheel Right” and “Button Horiz Wheel Left” from my touchpad with this command

>> xinput set-button-map "ETPS/2 Elantech Touchpad" 1 2 3 4 5 0 0

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.