How to disable Turbo Boost on HP omen DH series laptop

I want to disable Turbo Boost while playing CSGO as it keeps my temp lower.With Turbo boost on ,temp reaches to 99 degree Celsius, and if I disable it temp won’t go beyond 80 degree celsius. I was using throttlestop in windows to disable turbo boost. Is there any similar app which can do that?

You mean, forever? Or for just when playing CSGO?

This one should disable it on both of the AMD/Intel aswell I think
echo 0 > /sys/devices/system/cpu/cpufreq/boost

Don’t forget to turn it back to 1 if you want to keep having turbo after you finished playing. Also it will not persist between reboots.
But better yet fix your cooling :slight_smile: PCs should not overheat that easily.

bash: /sys/devices/system/cpu/cpufreq/boost: Permission denied

Yep, you have to do this with sudo and provide password.

Turbo boost is system wide setting.

Yes I did with sudo but still I am getting this. Tried with su still I am getting same thing.

echo 1 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo . This one is working fine. 1 means turbo is disabled and 0 means its enabled. Thank You. :smile:

1 Like

No problem, I don’t know why we can’t echo to /sys/devices/system/cpu/cpufreq/boost with sudo. I can’t either on Manjaro however I can do it from root user.

I thought users in the wheel + sudo can do anything. :open_mouth: I was wrong

1 Like

Ah bash bit me in the butox.

It was the file redirection
The correct way is to invoke shell (bash if default) and run the command on it’s own.

The correct way to do it from user shell

$ sudo sh -c 'echo 0 > /sys/devices/system/cpu/cpufreq/boost'

I tried this but I am still getting permission denied. :sweat_smile:

then I am lost :smiley: it’s true that I don’t use Bash for SH. But so weird :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.