How to disable the KDE Wallet Service popup about chrome?

Update

Solved by change the password to blank.
check this link for details


I don’t want to disable the kwallet. because if I disable it, the password in chrome will not work. So some posts just disable kwallet or --password-store=basic not work for me.

image

in i3 I already start the /usr/lib/pam_kwallet_init at start

exec --no-startup-id /usr/lib/pam_kwallet_init

Journal -b:

Jun 24 08:01:28 ori sddm-helper[939]: [PAM] Starting...
Jun 24 08:01:28 ori sddm-helper[939]: [PAM] Authenticating...
Jun 24 08:01:28 ori sddm-helper[939]: [PAM] Preparing to converse...
Jun 24 08:01:28 ori sddm-helper[939]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: pam_sm_authenticate
Jun 24 08:01:28 ori sddm-helper[939]: [PAM] Conversation with 1 messages
Jun 24 08:01:28 ori sddm-helper[939]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Couldn't get password (it is empty)
Jun 24 08:01:28 ori sddm-helper[939]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Empty or missing password, doing nothing
Jun 24 08:01:28 ori sddm-helper[939]: [PAM] returning.
Jun 24 08:01:28 ori dbus-broker-launch[722]: Activation request for 'org.freedesktop.home1' failed: The systemd unit 'dbus-org.freedesktop.home1.service' could not be found.
Jun 24 08:01:28 ori sddm[876]: Authentication for user  "lizhe"  successful
Jun 24 08:01:28 ori sddm-helper[939]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
Jun 24 08:01:28 ori sddm-helper[939]: pam_unix(sddm-autologin:session): session opened for user lizhe(uid=1000) by lizhe(uid=0)

So how to make it autologin and dismiss the popup. And I need the password works.

Looks like you have not set a password on the wallet.
Which would somewhat defeat the purpose.

For comparison here is what it looks like on my (plasma) system…

$ journalctl -b | grep -i kwallet
sddm-helper[1034]: pam_kwallet5(sddm:auth): pam_kwallet5: pam_sm_authenticate
sddm-helper[1034]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
sddm-helper[1034]: pam_kwallet5(sddm:session): pam_kwallet5: pam_sm_open_session
sddm-helper[1091]: pam_kwallet5: final socket path: /run/user/1000/kwallet5.socket
systemd[1043]: Started Unlock kwallet from pam credentials.

Also keep in mind that kwallet can only be opened automatically while using automatic login if you use something that saves the password, such as by pam_autologin.

Here is the archwiki with most needed information:
https://wiki.archlinux.org/title/KDE_Wallet

I change the password to blank and seems works. Right now.

In fact I set the password already I notice that at first. Which is wierd for me.
New log file

Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: pam_sm_authenticate
Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Couldn't get password (it is empty)
Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Empty or missing password, doing nothing
Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: pam_sm_open_session
Jun 24 08:56:41 ori sddm-helper[935]: pam_kwallet5(sddm-autologin:session): pam_kwallet5: open_session called without kwallet5_key
Jun 24 08:56:42 ori systemd[940]: Started Unlock kwallet from pam credentials.
Jun 24 08:56:49 ori xdg-desktop-por[1028]: Choosing kwallet.portal for org.freedesktop.impl.portal.Secret via the deprecated UseIn key
Jun 24 08:58:43 ori systemd[940]: Created slice Slice /app/dbus-:1.2-org.kde.kwalletd6.
Jun 24 08:58:43 ori systemd[940]: Started dbus-:1.2-org.kde.kwalletd6@0.service.
Jun 24 08:58:43 ori kwalletd6[3264]: Qt: Session management error: None of the authentication protocols specified are supported

I check that it said that. And autologin activated.
For SDDM no further edits should be needed because the lines are already present in /etc/pam.d/sddm.

Thanks anyway.

Yes … but, as mentioned, will not work for automatic login.
If you use SDDM regular … you cannot use automatic login and expect the wallet to open.
Furthermore your wallet password should match your user password.

So

  • Automatic login disabled.
  • Wallet password equals user password.

This will result in the wallet opening on login, which will retrieve stored and encrypted credentials, and not bother you again.

PS.
You marked your post as the solution, but it is not clear how a solution was reached.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.