How to disable password when wake on suspend?

Hi all, just installed Manjaro xfce edition on my laptop. I changed the settings so that it goes to suspend when I close my laptop lid, or when I press my power button. Although it works, I get a password prompt when I open the lid, which I don’t want. How do I disable that password prompt?

I went into xfce power manager, clicked security tab, and set “automatically lock the session” to never. I also unchecked the box that says “lock screen when system is going to sleep”. I also went into “session and startup” and unchecked the box that says “lock screen before sleep”. Not sure what the difference is between that one and the one in the power manager, but I unchecked them both. Problem still persists, so there must be some other setting somewhere that I can’t find.

Funny thing, when I suspend by pressing the power button, and then press power button again to wake it, I do NOT get a password prompt, I get the desktop immediately just like I want. It’s only the closing/opening the lid which gives me the password prompt.

1 Like

Security is paramount and built into Linux.

Disabling security features is not recommended.

Trying to disable and/or cirucumvent these features is possible - but it is a pain to maintain.

The best advise you can get is - live with it and learn to appreciate.

And the ongoing topics - which long time members has eeen again and again - this is tearing on our patience - please do search before asking - maybe search the archive too

Freedom of choice is even more paramount. If I want to disable something, there should be a way to do it. It’s my computer, I get to decide what features I need or don’t need. Why did you even bother replying with such an unhelpful answer? Furthermore, I don’t see how disabling a lock screen password prompt (on a computer that never leaves my home, where I live alone) is compromising my security in the slightest. Let me decide what security features I need.


Hey @Beefshh Keep it top secret… :stuck_out_tongue:

pamac remove xfce4-screensaver light-locker

And it is gone.

cat $(which xflock4)

There are some troubles handling the laptop lid on Xfce. See the similar issues for fixes/workarounds:

That did it, thanks

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.