How to disable kde wallet permanently?

I did not even set password for kde and it keep asking me. I disable the kde wallet and rebooted… then it didnt ask me again until i change the name of my profile… how to retrieve the password?

What you screenshotted isn’t actually kwallet asking for a password, but the system asking you for your account password, probably because you are trying to change something important. The kwallet and login passwords are different things, because they have different uses.

Kwallet is a password manager. Its main function is to store other passwords, things like your mail login, your chat login details and all your other passwords, and store them in an encrypted file. It’s generally a good idea to use it, since it makes it easy to store all kinds of different, complex passwords in a safer way while still keeping it simple, since you only have to remember the kwallet password instead. I imagine though that most people have emigrated to using a browser based password manager instead, and in that case it should be enough to just press ok without entering a password, if I remember right. Do note that this will store the passwords you choose to save in a plain database though!

As for disabling a user password, I’m not sure if that’s something you can do without things breaking. I know you can set kdm to autologin without a password, but I think you still need to have a user password for authentication when you do system stuff.

If it’s just about Kwallet - that can very well be completely disabled. You should be able to find it somewhere in the settings under User (I don’t have KDE running here at the moment, so I can only tell you from memory). Search in the settings under User for password manager. The service can then be deactivated there simply by checking the box.

i remember at some point i either changed the user name or password and kde wallet would not stop bugging me asking for a password which i gave, but i couldn’t get rid of it,it kept coming back on restart and during the session for various reasons .
good thing i had another reason to reinstall the system,and now when i browse the system settings I’m very careful not to click on it and invoke it by mistake.

I’m also interested in knowing how to disable or remove it.

Search in the settings under User for password manager. The service can then be deactivated there simply by checking the box.

Read and understand :wink:

1 Like

i saw you comment and looked for it but couldn’t find any related checkbox.
now went again and typed user,password and manager but nothing.
i might be missing it and need an exact path.
thanks
EDIT
i just looked it up and there seem to be many threads about it so I’ll report back if i find anything.
also i don’t have it enabled right now,so maybe that’s why i find that checkbox,but i’d prefer not have kde wallet at all.

I told you that I don’t use KDE anymore right now. So I can’t say for sure WHERE this setting can be found. Maybe someone will get in touch here who can describe it more precisely. I will not install extra KDE on my computer because of this, sorry. If you go through all the settings, you will inevitably come across this.

like i said,i probably couldn’t find this checkbox because kde wallet isn’t enable on my system.
any how i found some threads that might help op:

https://bbs.archlinux.org/viewtopic.php?id=202174

System Settings->KDE Wallet Unclick the button that says “Enable the KDE Wallet subsystem”

1 Like