How to disable Dwell click in Xfce?

I’m afraid that i will erase something by mistake.

I looked for “dwell click” (Google) and found references to “mouse hover click”
This suggests that you installed something that enabled it.
“mousetweaks” … perhaps?

Try uninstalling it - I do not know it or whether and how it is to be configured.

In “normal” Xfce4 I wouldn’t know where that setting would be or whether it is even available.

The shorter question and path to the answer would be:
how did you enable that behaviour?

In XFCE, I found:

gsettings list-recursively org.gnome.desktop.a11y.mouse

# ...
# org.gnome.desktop.a11y.mouse dwell-click-enabled false
# ..

dwell click at gnome

You can change it via the command line (gsettings set org.gnome.desktop.a11y.mouse dwell-click-enabled false) or by using the dconf Editor (package dconf-editor).

I agree with @Nachlese, how was it set in the first place. Just undo that :slight_smile:

Made it False but Xfce still hover clicks. So totally unrelated. Should i build something my self?

I just checked a default Manjaro Xfce .iso and the right click hover-clicks by default when you release it. I checked another mouse did the same and i also checked Windowz where i’m clear.

It is my understanding that dwell click involves no clicking, just the fact that the mouse is hovering over an actionable area is enough. I think we might be talk’n about something else.

In a VM I built with manjaro-xfce-21.3.7-220816-linux515, I could not repeat the problem. When I right click, the context menu is displayed. When I hover over the menu items, the item becomes selected, but there is no action until I left click

It almost sound like this post at xfce.

When i Right Click and Release - the Release Action - always acts like Left Click even if the Release is like 1ms long. Basically all Right Clicks behave like Right - Hold - Clicks and when you Release you are in danger to choose something wrong from the Pop Up Menu the Right Click usually activates.

I’ve been playing around with this a bit. I’m using Thunar to test.

When you release, is anything selected (highlighted) in the context menu?

Are you releasing immediately, without moving the mouse?

A left or right click is just a click or tap. If you want a user to hold (not release), usually it’s

For example (1), if I right click a file name (and release), nothing is selected in the context menu. The context menu is still displayed and I can move the mouse over the menu items. As I move the mouse over the context menu, the menu items become selected (highlighted). If I want a menu item, I left click the item. If I don’t, I either click on the destop or hit ESC.

For example (2), if I right click + hold a file name, still nothing is selected in the context menu. The context menu is still displayed and I can move the mouse over the menu items. As I move the mouse over the context menu (right click still held), the menu items become selected (highlighted). BUT NOW, when I release the right click while a menu item is selected, it executes.

Does this sound like what is happening? Make sure the click is just a tap, or barring a better solution that meets your needs, hit ESC before releasing to close the context menu.

Can’t replicate.

Nothing like what you describe happens.

Have never seen anything close to the description
and certainly not in a default install
and definitely not in the just booted up Manjaro iso of Xfce edition.


When i Left Click if i move just a pixel then the Release Counts as Hold_Release aka Left Click. Even if i Release as fast as a human can, a pixel hand tremble movement chooses a Highlighted option from a Pop Up Menu.

You maybe have a mouse with a trackball instead of light. For all today’s mouses a pixel movement by an accidental hand tremble will reach analysis first than even the fastest possible Left Click Release. I will donate you a 2022 mouse if you are in need. This is the default Xfce Manjaro behavior and please people don’t waste my time. If someone knows the solution is welcomed to tell, if not there is no reason to write anything.

Searching this forum, I came across your previous question on this topic.

Definitely search this forum. Also search This one might be helpful. Here is the link to the arch wiki on libinput.

I don’t have anything more to add to this topic.

no need for a donation and no need to be rude
I do have a totally standard, modern mouse from last year. Optical, not mechanical.
But these work just as well.
As well as the touchpad …

I can understand that you may be frustrated - but perhaps think of a way to describe your issue differently.

It sounds a bit that what you actually mean is the “sensitivity” -
how much movement after having pushed a button counts as having moved the object that you picked up
by having pushed the button and then letting go of it again.

If one has shaky hands, the default sensitivity might be too high …

Go to mouse settings via menu, or in terminal:
LANG=C xfce4-settings-manager → Mouse and Touchpad
or directly:
LANG=C xfce4-mouse-settings → choose your mouse device from the list
then go to the “Behavior” Tab and adjust the Drag and Drop Threshold

That right here is totally standard behavior - the way you described your issue with it it led me astray and probably others as well.

Dwell click is not a term I have seen before on Xfce and is not included with Xfce settings for accessibility

There is Gnome package mousetweaks that has accessibility options to adjust --dwell
mousetweaks(1) — Arch manual pages
I can’t find any previous discussions on this forum; archived forum or information on Archwiki

Maybe you could install that package to configure mouse clicks for your hardware?

I did that before with many different ways, Gnome configuration and apps don’t work. In libinput model @stargazer suggests, i cannot find anything for dwell-click because that is what it is. As far as the suggestion to touch sensitivity, well: I’m a pro player and money is involved, there is no way. So lets drop this if no one has an idea, i will write to Xfce Git for a solution. At any rate please take note that this is the default behavior for future development because Xfce have really taken the wrong turn.

dropped as requested