How to disable a faulty resolution mode

How to disable a resolution mode?

Hi everyone. Bear with me, this is my first month of using Linux. So far I’m liking but I do run into issues here and there like this one. So my computer is having an issue where whenever it tries to display 1920x1080 at 120hz the screen goes black. This happens with a couple games I play, but I can mimic it with my desktop resolution. However when it’s a game even if I restart my desktop is retains the broken resolution and I have to reboot into TTY and do a complete reinstall of my Nvidia drivers. Xrandr “Can’t open display” if I try anything with it until reinstalling the drivers.

I figure I would fix my problem of certain games basically borking my computer if I could find a way to disable that resolution but I’m not quite sure how to do that. Any help would be greatly appreciated.

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  1. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  2. the output to xrandr would also be needed to help you disable a resolution.

:innocent:

1 Like

Sorry for the late reply, I’ve been without internet for a couple weeks. Here is the readout of the inxi command

System:
  Kernel: 5.4.72-xanmod1-1-xanmod-lts x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux-xanmod-lts 
  root=UUID=54952014-8d3a-4e59-bc9d-a679aea438e3 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: MSI model: 990XA-GD55 (MS-7640) v: 4.0 serial: <filter> 
  BIOS: American Megatrends v: 22.5 date: 10/12/2012 
Memory:
  RAM: total: 15.60 GiB used: 4.88 GiB (31.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: 8-Core model: AMD FX-8320 bits: 64 type: MCP arch: Bulldozer 
  family: 15 (21) model-id: 2 stepping: N/A microcode: 6000852 
  L2 cache: 2048 KiB bogomips: 56008 
  Speed: 3701 MHz min/max: 1400/3500 MHz boost: enabled Core speeds (MHz): 
  1: 3701 2: 3701 3: 3701 4: 3701 5: 3701 6: 3701 7: 3701 8: 3701 
  Flags: 3dnowprefetch abm aes aperfmperf apic arat avx bmi1 clflush cmov 
  cmp_legacy constant_tsc cpb cpuid cr8_legacy cx16 cx8 de decodeassists 
  extapic extd_apicid f16c flushbyasid fma fma4 fpu fxsr fxsr_opt ht hw_pstate 
  ibpb ibs lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor msr mtrr 
  nodeid_msr nonstop_tsc nopl npt nrip_save nx osvw pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse 
  pse36 rdtscp rep_good sep skinit ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 svm 
  svm_lock syscall tbm tce topoext tsc tsc_scale vmcb_clean vme vmmcall wdt 
  xop xsave 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: eVga.com. driver: nvidia 
  v: 440.100 alternate: nvidiafb,nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1401 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 80 s-size: 1219x686mm (48.0x27.0") 
  s-diag: 1399mm (55.1") 
  Monitor-1: HDMI-0 res: 3840x2160 dpi: 81 size: 1210x680mm (47.6x26.8") 
  diag: 1388mm (54.6") 
  OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: NVIDIA GM206 High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fba 
  Device-3: Razer USA Gaming Headset [Kraken USB] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 4-5:5 chip ID: 1532:0502 
  Sound Server: ALSA v: k5.4.72-xanmod1-1-xanmod-lts 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: steamos-xpad 
  bus ID: 4-2:2 chip ID: 045e:0719 serial: <filter> 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 3.18 TiB used: 1.93 TiB (60.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC34 scheme: MBR 
  ID-3: /dev/sdc vendor: Western Digital model: WD15EARS-00Z5B1 size: 1.36 TiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 0A80 scheme: MBR 
  Optical-1: /dev/sr0 vendor: Memorex model: MRX-550L v5 rev: RM62 
  dev-links: cdrom 
  Features: speed: 125 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 719.01 GiB size: 706.72 GiB (98.29%) 
  used: 147.44 GiB (20.9%) fs: ext4 dev: /dev/sda1 label: N/A 
  uuid: 54952014-8d3a-4e59-bc9d-a679aea438e3 
  ID-2: /run/media/ki/08ECAC6AECAC53AA raw size: 207.13 GiB 
  size: 194.82 GiB (94.06%) used: 174.55 GiB (89.6%) fs: ntfs dev: /dev/sda3 
  label: N/A uuid: 08ECAC6AECAC53AA 
  ID-3: /run/media/ki/Charmander raw size: 931.51 GiB 
  size: 915.89 GiB (98.32%) used: 757.60 GiB (82.7%) fs: ext4 dev: /dev/sdb1 
  label: Charmander uuid: 8f6584f6-113b-4d4e-9461-375bea3a7b77 
  ID-4: /run/media/ki/Togapi raw size: 1.01 TiB size: 1017.91 GiB (98.33%) 
  used: 599.32 GiB (58.9%) fs: ext4 dev: /dev/sdc1 label: Togapi 
  uuid: 30b88505-3ff7-44f8-acd0-93001f94f814 
  ID-5: /run/media/ki/WinData raw size: 362.11 GiB size: 362.11 GiB (100.00%) 
  used: 294.93 GiB (81.4%) fs: ntfs dev: /dev/sdc2 label: WinData 
  uuid: 36022BA50DAE9BD4 
  ID-6: /run/timeshift/backup raw size: 719.01 GiB 
  size: <superuser/root required> used: <superuser/root required> fs: ext4 
  dev: /dev/sda1 label: N/A uuid: 54952014-8d3a-4e59-bc9d-a679aea438e3 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sda2 size: 500.0 MiB fs: ntfs label: System Reserved 
  uuid: E02895CB2895A158 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Device-1: 4-2:2 info: Microsoft Xbox 360 Wireless Adapter 
  type: <vendor specific> driver: steamos-xpad interfaces: 8 rev: 2.0 
  speed: 12 Mb/s chip ID: 045e:0719 serial: <filter> 
  Device-2: 4-3:3 info: Razer USA Ornata Chroma type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 1532:021e 
  Device-3: 4-4:4 info: Corsair Corsair Gaming HARPOON RGB Mouse 
  type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s chip ID: 1b1c:1b3c serial: <filter> 
  Device-4: 4-5:5 info: Razer USA Gaming Headset [Kraken USB] type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1 
  speed: 12 Mb/s chip ID: 1532:0502 
  Hub: 5-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Device-1: 5-5:2 info: Valve Wireless Steam Controller type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s 
  chip ID: 28de:1142 
  Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Hub: 7-0:1 info: Full speed (or root) Hub ports: 4 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Hub: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 9-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 70.0 C mobo: N/A gpu: nvidia temp: 41 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 294 Uptime: 3h 56m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  clang: 10.0.1 Packages: apt: 0 pacman: 1397 lib: 365 flatpak: 0 Shell: Bash 
  v: 5.0.18 running in: konsole inxi: 3.1.05 

And here is the readout for xrandr

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 1210mm x 680mm
   3840x2160     30.00 +  59.94*   29.97    23.98  
   4096x2160     59.94    29.97    24.00  
   1920x1080    120.00   119.88    60.00    59.94    23.98    60.00  
   1280x720      60.00    59.94  
   720x480       59.94  
   640x480       59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

While in 4K resolution, execute:

xrandr --delmode HDMI-0 1920x1080_120.00
sudo reboot

and that mode will be gone forever¹ and nothing will be able to switch to that mode again.

Note 1: Until you add it back in again manually

I try but when I run the command it gives me xrandr: cannot find mode “1920x1080_120.00

try 1920x1080 all by itself then.

:thinking:

I tried xrandr --delmode HDMI-0 1920x1080_120.00. I’ve also tried xrandr --delmode HDMI-0 1920x1080 and xrandr --rmmode HDMI-0 1920x1080_120.00 and variations between 1920x1080_120, 1920x1080, 1920x1080_120.00, --rmmode, --delmode and so on. I’m pretty confused but I really appreciate the help Fabby.

An I’m sorry but can’t help you any further because:

xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     75.00*+

I only have one!

You did try:

Right?

Yes even with sudo nothing. I appreciate the help though.

1 Like