How to determine why Core 2 of 8 has CPU usage 100% constantly?

Hello, Would you please provide some direction on how to go about determining what is using CPU when no applications are open except System Monitor?

I noticed that the CPU was jumping between 13% and 20% with no apps. open and tried looking at processes and tried looking using Htop but that was equllay challenging for me. I shutdown/rebooted twice with no change.

Anyway, I stumbled across the part of System Monitor that shows usage by core. I have an HP Elitedesk with 8 cores and noticed that core 2 shows 100% constantly.

How can I figure out what that means, such as is core 2 being used or damaged?

I’m pretty sure that CPU usage is usually very low on my machine (as I use it, anyway) because sometimes I watch it when doing what, for me, are complicated data reads, manipulation, and writes to SQLite databases that last for a couple hours and CPU usage remains at about 15% throughout.

Thank you for any guidance you may be able to provide.

I think I figured it out. I have a LAMP stack on the machine but haven’t used it in several months. It appears that for some reason, HTTPD and MariaDB were started again at startup and were using 100% of Core 2. After trying systemctl stop mariadb and systemctl stop httpd, Core 2 went to 0%; and total CPU jumps around from 0.5 to 4% again.

When looking at the CPU usage by process, neither of these showed a value for CPU usage though. Why, when a core is at 100%, does the process list not show a value?

I started httpd and mariadb, again, to see what would happen and Core 5 goes to 100%; but when I look in System Montior by process and see them listed, the CPU value for both is blank.

Thank you.

Probably the same as the reported-in-12-other-threads issue of mariadb+akonadi

(its also just cosmetic)

Thank you for the response.

I assume it must be related since stopping mariadb and httpd resolved it. However, I don’t have akonadi installed; don’t recall why I got rid of it but did quite some time ago.

pactree -r akonadi 
error: package 'akonadi' not found

I also don’t have Kmail or Kalendar installed.

Running kernel 5.15 but have 6.1.44-1 installed.


While I believe the only examples I saw were it being caused by akonadi … it was technically an issue between mariadb and the kernel … so I suppose it happening without it is entirely plausible.

Yeah, it’s mariadb. I don’t use akonadi either but I do have mariadb running all day for work and I see it.

It’s just a cosmetic issue, ignore it. It’s already been fixed in htop and many other tools but not in KDE System Monitor which still shows one core pegged at 100%.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.