How to create a usb?

After a brief test in vbox and knowing you have Deepin and great support, i have decided to install manjaro. However, startupdiskcreator does not work. I tried the dd command.
(I renamed the iso to be simpler)
It took about 8 minutes which seemed right.
However, my machine won’t boot from the disk and the boot flags are set.

sudo dd if=~/Downloads/manjaro.iso of=/dev/sda1 bs=4M && sync

The ISO is written to the device - not the partition - so dd will be - (with couple of flags to ensure sync while writing and progress display)

Replace $DISK with your device e.g. /dev/sda or set the variable beforehand and use the line as is

$ DISK=/dev/sda
$ sudo dd if=~/Downloads/manjaro.iso of=$DISK bs=4M conv=noerror,notrunc oflag=sync,nonblock status=progress

is sdy correct or should it be sd1?

replace sdy with your device - do not use partitionnumber

e.g. /dev/sda NOT /dev/sda1

~$ lsblk
loop0 7:0 0 55.4M 1 loop /snap/core18/1944
loop1 7:1 0 55.4M 1 loop /snap/core18/1932
loop2 7:2 0 197.2M 1 loop /snap/flutter/44
loop3 7:3 0 162.9M 1 loop /snap/gnome-3-28-1804/145
loop4 7:4 0 31.1M 1 loop /snap/snapd/10492
loop5 7:5 0 193.4M 1 loop /snap/flutter/46
loop6 7:6 0 64.4M 1 loop /snap/gtk-common-themes/1513
loop7 7:7 0 64.8M 1 loop /snap/gtk-common-themes/1514
loop8 7:8 0 38M 1 loop /snap/review-tools/1720
loop9 7:9 0 67.8M 1 loop /snap/snapcraft/5821
loop10 7:10 0 31.1M 1 loop /snap/snapd/10707
loop11 7:11 0 211.5M 1 loop /snap/tipitaka-pali-projector/4
loop12 7:12 0 216.5M 1 loop /snap/tipitaka-pali-projector/5
loop13 7:13 0 38.1M 1 loop /snap/review-tools/2014
loop14 7:14 0 67.8M 1 loop /snap/snapcraft/5807
sda 8:0 1 3.8G 0 disk
└─sda1 8:1 1 3.8G 0 part
nvme0n1 259:0 0 238.5G 0 disk
├─nvme0n1p1 259:1 0 100M 0 part /boot/efi
├─nvme0n1p2 259:2 0 16M 0 part
├─nvme0n1p3 259:3 0 68.4G 0 part
├─nvme0n1p4 259:4 0 1G 0 part
├─nvme0n1p6 259:5 0 106.8G 0 part /
└─nvme0n1p7 259:6 0 62.2G 0 part /mnt/Data

okay… trying now. sudo dd if=~/Downloads/manjaro.iso of=/dev/sda bs=4M conv=noerror,notrunc oflag=sync,nonblock status=progress

Deepin is in a flux - while packages may exist - it has a history of being highly unstable on Manjaro.

will Deepin mess up my system, or just that desktop? I did a pacman install from kde manjaro vm and it seemed like it worked.

The base system without wayland or Xorg is never affected - there is no guarantee it won’t break the graphical system.

And we have very few deepin experts knowing what may have went wrong and how to fix it.

This should not stop you from trying … the members will try to help if possible - I just feel a heads-up will be fair.

okay… since i’m new to manjaro… maybe I’ll back off for a while on that.

okay… it worked… i can boot. What is the admin password if i want to use kparted or gparted.from usb?

root and user password on live ISO is: manjaro

1 Like

okay… I’m signed in with my new manjaro kde install. When I did the dde first… i accidentally did
sudo dd if=~/Downloads/manjaro.iso of=/dev/sd1 bs=4M && sync

It did something in 5 seconds… I’m wondering what it did.

The Grub seemed to boot into nothing… then i checked the boot order. there is a manjaro boot and that worked… However, when i did a full bios boot priority order, there was no listing for Manjaro. So I put the last two blank lines first and now it boots manjaro… what is this? Is there a way to fix this?

I have other questions but i’ll make new threads for them

It tried to overwrite for 5 seconds /dev/sd1. Luckily, this is no proper device name, so most likely nothing happend. NEVER EVER apply dd command before you have double checked the destination!!!

If you cannot keep you fingers still then better forget dd command, it can damage your installation pretty quickly if used with wrong syntax.

1 Like

i know… i wanted sda1 (even though that was wrong… see top post).
I think dde is just a hair lower to bios update