How to create a system backup?


I am looking for a program with which I could create a complete backup of the full system to external hard disk.

I tried TimeShift but it doesn’t work properly on my system Manjaro kde-plasma ARM (rpi4) 22.08

Can anyone suggest a suitable alternative?


Have you seen this?

1 Like

Search and you shall find:

Edit: If you use a sd card as OS drive, making a disk image should be a good option, some of the steps in the linked post should be the same, the tech might be different. I use the gnome disks app to create backup images of running pi systems on SD cards that would take longer then a manual config to restore.

1 Like

To back up the system when it is turned off, I use:

But I have a problem with Timeshift, I can’t run it through the shortcut.
It can only run be done in the terminal via the command: sudo timeshift-gtk

Does anyone know how I should edited the shortcut?

this change does not work (the program does not start) and without sudo it says that I do not have the necessary permissions.

No experience with KDE but this thread suggests pkexec

no wok for me :frowning:

timeshift-launcher is the command for the GUI. It should ask for polkit access, so no sudo needed.


this command was there initially, but after entering the password, nothing happens

Have you tried timeshift-launcher from terminal? If there are errors it will print in the terminal.
It seems a bit the application is not correctly reported to polkit.
Please click on Podrobnosti to see which application requests access.


Check what your timeshift-launcher file says:

 cat /bin/timeshift-launcher  

Are you running it as root user?

Also check existing polkit policy:

ls /usr/share/polkit-1/actions/ | grep timeshift 

cat /bin/timeshift-launcher



if [ "$(id -u)" -eq 0 ]; then
        # user is admin
        # user is not admin
        if echo $- | grep "i" >/dev/null 2>&1; then
                # script is running in interactive mode
                su - -c "${app_command}"
                # script is running in non-interactive mode
                if [ "$XDG_SESSION_TYPE" = "wayland" ] ; then
                        xhost +SI:localuser:root
                        pkexec ${app_command}
                        xhost -SI:localuser:root
                elif command -v pkexec >/dev/null 2>&1; then
                        pkexec ${app_command}
                elif command -v sudo >/dev/null 2>&1; then
                        x-terminal-emulator -e "sudo ${app_command}"
                elif command -v su >/dev/null 2>&1; then
                        x-terminal-emulator -e "su - -c '${app_command}'"
                        x-terminal-emulator -e "echo 'Command must be run as root user: ${app_command}'"

ls /usr/share/polkit-1/actions/ | grep timeshift


My name user: voboda

As @raguse already pointed out, it should be timeshift-launcher. This is also how it is by default, so you had to change it to sudo timeshift-gtk yourself.

yes I changed it because this doesn’t work, do you understand me?

timeshift-launcher = GUI not wok

sudo timeshift-gtk = GUI not wok

timeshift-launcher = Terminal not wok

sudo timeshift-gtk = Terminal wok

Ah, this is ARM. Does timeshift even work on ARM? - I don’t know. :man_shrugging: Last time i played with it on archlinuxarm it didn’t work IIRC.

EDIT: I just use borg with borgmatic now.

sudo timeshift-gtk = Terminal wok

I want to use a shortcut, but it doesn’t work and I don’t know why.

This looks all ok.

timeshift-gtk works because you are bypassing polkit with it.

Yes, it does. You posted a screenshot of it above.

Is there any output in the terminal after running that command?

Never run GUI applications with sudo. See Running GUI applications as root - ArchWiki

Please post the output of:

pacman -Qs polkit


1 Like