How to connect an ANDROID-phone with USB for file transfer?

My new REDMI phone does not allow file transfers over USB. In Developer-Options, the phone is set to File-Transfer Anroid-Auto. The PC has installed gvfs, gvfs-mtp and mtpfs.
What else might be missing or how to allow file transfer over USB?

When you connect your phone via USB, do you see a Charging this device via USB notification? If so, choose it and select File Transfer.

The setting in Developer Options doesn’t actually seem to work.

Have you tried kde connect to see if that allows it?

Yes, I see the options: No Tranfer, File Transfer (AKTIVE) and Photos (PTP)

Is your phone detected? Do you see it appear in your file manager (probably Dolphin)? Does it appear running lsusb?

Thank you

Yes, and yes

When I plug in my android phone in Dolphin it shows up in devices.
I then pull down from the top on the phone and scroll down where it says Android system and it says
Charging this device via USB
Touch for more options.
I touch that and select file transfer.
Close Dolphin and reopen it and it shows the files on the android phone.

I have the same problem with a Moto G8 Power and Manjaro KDE.
The phone is shown as a device, Doplhin opens it but it keeps “Loading…” forever.
I have always used KDEConnect as a workaround but now I have to move a lot of GB and I would like more speed.

No MANJARO-issue at all, more an user-caused problem. I have it now working as follows:

  • Switch the MobilePhone ON and unlock it.
  • The mobile’s screen shall be bright when plugging the USB-cable!!
  • Check, that the USB-option “File Transfer” as defined in the DeveloperOptions (ref. above) is still active, click on this line.
  • Enjoy the data-transfer …

It doesn’t work for me.
Dolphin says: “No storage device found. Check that your device is unlocked and MTP is enabled in USB connection settings.”
If i select “PTP” instead of “File transfer” on my phone, i get:
“File or folder udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:08.1/0000:27:00.4/usb5/5-1 doesn’t exist”.

Update: i let the phone’s screen turn down, then I opened Dolphin again (it opens on the last folder used, so it opened on my phone) and this time it worked.
I started the file transfer, but it stopped after a while. For Dolphin the transfer is still going on, but at zero speed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.