How to Configure xrdp/xfreerdp?

I’ve just installed Manjaro and also xrdp to be able to use my main machine to connect to it with xfreerdp. I followed a guide that I’m not allowed to post a link of (why???), which basically says “install xrdp, enable it and connect to it”.

lsof on the server shows that it listens and receives connections, but running xfreerdp fails:

$ /usr/bin/xfreerdp /v:10.0.0.102 /u:user /p:pwd
[17:27:44:788] [9800:9801] [WARN][com.freerdp.crypto] - Certificate verification failure 'self signed certificate (18)' at stack position 0
[17:27:44:788] [9800:9801] [WARN][com.freerdp.crypto] - C = US, ST = CA, L = Sunnyvale, O = xrdp, CN = www.xrdp.org
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - @           WARNING: CERTIFICATE NAME MISMATCH!           @
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - The hostname used for this connection (10.0.0.102:3389)
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - does not match the name given in the certificate:
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - Common Name (CN):
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] -        www.xrdp.org
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - A valid certificate for the wrong name should NOT be trusted!
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.crypto] - certificate not trusted, aborting.
[17:27:44:788] [9800:9801] [ERROR][com.freerdp.core] - transport_connect_tls:freerdp_set_last_error_ex ERRCONNECT_TLS_CONNECT_FAILED [0x00020008]

So how do I set up such a thing? I mean I haven’t generated a certificate (how? where would I put it?) nor have I found a certificate that would check for the xrdp.org-host so I would circumvent it somehow.

If I ignore the certificate like so:

$ /usr/bin/xfreerdp /v:10.0.0.102 /u:user /p:pwd /cert:ignore

I get this pop-up inside the window (why can’t I post images???):

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login failed for display 0

What now?

Both machines have the latest stable Manjaro installed with XFCE.

Guide: wiki-dot-archlinux-dot-org/index.php/Xrdp

Hello,

Did find a solution for Xrdp on Lanjaro xfce ? I have more or less the same issue.
It would be a great help if we can exchange on that.

Thanks
Christophe

Because images was - at least partly - one of the reason the previous forum installation is now archived.

Also images are not searchable - and therefore of little interest.

Nope, still waiting for anyone to help out here…

Hello,

Now It is almost working. I can use xrdp (on Manjaro xfce) with Remmina on Manjaro KDE. I am not using xfreerdp. This is what I did :

I followed the instructions here : Xrdp - ArchWiki

  • install xrdp
  • enable & start the services : xrdp.service et xrdp-sesman.service

install de xorgxrdp-git
Add allowed_users=anybody to /etc/X11/Xwrapper.config to allow anybody to start X

BUT I modified the ~/.xinitrc (replace the latest line) :

#exec $(get_session “$1”)
exec dbus-launch --sh-syntax --exit-with-session xfce4-session

I don’t know why it is working like this and not with the default line in this file. It seems that the argument is not well injected via a remote desktop session.

My latest issues :

  • I can’t add/remove program in a remote dekstop session or make an update. For exemple, in the “add/remore app”. It doesn’t ask me my password. Maybe I can control this in a config file ?
  • I have also some issues with the keyboard layout