How to configure pipewire to stop speaker continiously popping before first sound played


I use manjaro-pipewire and I had a problem of speaker constantly popping (a pop per second) when no sound was played.

Following a tips found on the pipewire gitlab (issue 1415 named "node.pause-on-idle option is being ignored. ") , I configured the file


by setting the option

[“session.suspend-timeout-seconds”] = 0

This removed all the annoying pop sounds as soon that a sound if played, but I still have pop sounds from the start of the session (even login scree) until the first music/sound I will play.

Do you have an idea in order to solve it?

Thanks for your help and attention!

According to the Archwiki the way to do this is


table.insert (alsa_monitor.rules, {
  matches = {
      -- Matches all sources.
      { "", "matches", "alsa_input.*" },
      -- Matches all sinks.
      { "", "matches", "alsa_output.*" },
  apply_properties = {
    ["session.suspend-timeout-seconds"] = 0,  -- 0 disables suspend


I tried it but sadly it doesn’t work.
It actually seems to have the same effect that the option i already set : no popping after a first sound is played.

I used the following “fix” until i find a proper solution: I play a sound at startup. ^^

That’s called a workaround. :wink: