How to change GTK2 themes on KDE plasma5.20?

I am a new user of Manjaro KDE plasma.I updated the system and the then installed apps.Then I changed my theme colors to dark but some apps like firefox , pamac , evolution,etc. did not sync up with the theme . I googled about it and I came to know that plasma 5.20 dropped support for changing themes.

Someone please help me to solve this.

See:

Thanks @Tomek

It worked for pamac and evolution but firefox , chromium and vivaldi haven’t changed.

Vivaldi doesn’t support system theming. Only way is Vivaldi settings.

They use their own theming, because they’re locked-down. You have to use themes from their respective app store.

Thank you so much @Aragorn It helped.
One more thing how to close this thread ?

You don’t need to. The forum engine will automatically close it in two weeks. :wink:

Plasma doesnt touch the ~/.gtkrc-2.0 file anymore.

I will leave here mine so you can use it to create or edit your own:

gtk-cursor-theme-size=32
gtk-enable-animations=0

# File created by KDE Gtk Config # This is a lie now ;-)
# Configs for GTK2 programs 


gtk-font-name="Noto Sans,  10"
gtk-theme-name="Breath-Dark"
gtk-icon-theme-name="Papirus-Adapta-Nokto-Maia"
gtk-fallback-icon-theme="breeze-dark"
gtk-cursor-theme-name="volantes_light_cursors"
gtk-toolbar-style=3
gtk-menu-images=1
gtk-button-images=1
gtk-primary-button-warps-slider=0

(this may or may not apply to your other examples … but its the fix for gtk2 theming, like gcolor2)

good afternoon,

is there a way to update the highlight colors to match the kde apps? i have tried systm settings-> app style -> configure gnome/gtk app style -> and it updates the window settings but not the highlight colors.

pretty much all gtk apps (mozilla, etc…) still highlight in green and different than kde.

not a major issue but not eye-pleasing.

any way to fix this?

If its gtk3 it should pick up your system colors fine
(System Settings > Appearance > Colors)
For gtk2 it will be tied to your gtk theme … see the post right above yours.

did not work unfortunately.

the behaviour is also reproduced on my laptop.

here is my system:

β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   OS: Manjaro Linux x86_64 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Host: HP Z440 Workstation 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Kernel: 5.9.11-2-MANJARO 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Uptime: 1 day, 10 hours, 9 mins 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Packages: 1367 (pacman) 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Shell: bash 5.0.18 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Resolution: 1920x1080, 1920x1080 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   DE: Plasma 5.20.3 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   WM: KWin 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   WM Theme: Oxygen 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Theme: Aritim-Light [Plasma], Aritim-Light-GTK [GTK 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Icons: oxygen [Plasma], oxygen [GTK2/3] 
                               Terminal: konsole 
                               Terminal Font: Lucida Console 10 
                               CPU: Intel Xeon E5-1620 v3 (8) @ 3.600GHz 
                               GPU: NVIDIA Quadro K2200 
                               Memory: 7887MiB / 32032MiB 



Did you try closing and reopening Firefox? I just did the following test to be sure (I’m using Breath2 colors by default).

  1. Open Firefox, highlight text in address bar. It’s green. Good.
  2. Close Firefox.
  3. Open β€œColors” setting, change to Breeze.
  4. Open Firefox, highlight text in address bar. It’s blue. Good.

i did and it worked on both laptop and desktop. thanks kindly for your help!

1 Like