How to change default browser in Telegram

I have changed the default Browser in Manjaro to Vivaldi. Somehow Telegram-Desktop does not apply the changes, it always opens the links in firefox. I didn´t find any settings in Telegram to choose the default browser. Can someone help?
Thank you
Michael

Hi @mistr,

What @linux-aarhus said, instead

AFAIK Telegram will use the system’s default browser, which is define in ~/.config/mimeapps.list. So please provide the output of:

cat ~/.config/mimeapps.list

Setting the default browser manually needs three commands to be effective.

$ b="firefox.desktop"
xdg-mime default "$b" x-scheme-handler/https
xdg-mime default "$b" x-scheme-handler/http
xdg-settings set default-web-browser $b

Or you can use this script

here the output of mimeapps.list:

cat ~/.config/mimeapps.list
[Default Applications]
application/octet-stream=mousepad.desktop
application/pdf=qpdfview.desktop
application/x-gettext-translation=mousepad.desktop
application/xml=mousepad.desktop
application/x-wine-extension-ini=mousepad.desktop
image/gif=viewnior.desktop;gimp.desktop
image/jpeg=viewnior.desktop;gimp.desktop
image/png=viewnior.desktop;gimp.desktop
text/plain=mousepad.desktop
video/mp4=vlc.desktop
video/ogg=vlc.desktop
video/x-flv=vlc.desktop
video/x-ms-wmv=vlc.desktop
video/x-ogm+ogg=vlc.desktop
video/x-theora+ogg=vlc.desktop
x-scheme-handler/tg=userapp-Telegram Desktop-PLA4J1.desktop
x-scheme-handler/mailto=xfce4-mail-reader.desktop
text/html=vivaldi-stable.desktop

[Added Associations]
text/plain=org.xfce.mousepad.desktop;
x-scheme-handler/tg=userapp-Telegram Desktop-PLA4J1.desktop;
x-scheme-handler/mailto=xfce4-mail-reader.desktop;
text/html=vivaldi-stable.desktop;
application/x-trash=org.xfce.mousepad.desktop;
image/jpeg=vivaldi-stable.desktop;
application/x-desktop=org.xfce.mousepad.desktop;

As you see, vivaldi is there defined as default browser. It is only telegram that goes with firefox

I defined it in “Settings Default Applications (Standardanwendungen)”

Obviously just correct the values, but see:

Edit:

I’m taking a random guess and saying it’ll be something like this:

xdg-settings set default-url-scheme-handler http vivaldi-stable.desktop
xdg-settings set default-url-scheme-handler https vivaldi-stable.desktop

This is what I get trying your method:

xdg-settings: default-url-scheme-handler not implemented for xfce

Seems to be a problem of XFCE

Do it manually then:

  1. Open mimeapps.list
nano ~/.config/mimeapps.list
  1. At the end of the [Added Associations] section, add the following two lines:
x-scheme-handler/http=vivaldi-stable.desktop;
x-scheme-handler/https=vivaldi-stable.desktop;
  1. Save, Ctrl+OY and Exit, Ctrl+X

  2. Followed either by a reboot, or a re-login.

Thank you, this did it.
Further question: Can I make the buil-in mailprogram of vivaldi my default mailto program?

I’m 100% sure it can, and would be done the same way.

However, I have never done this, I’ve never had the need to, so I don’t know exactly what would be necessary.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.