How to blacklist Intel SGX?

My motherboard has decided to make a setting unavailable , it is Intel " software guard extension "
or as it is reported in my log
“x86/cpu: SGX disabled by BIOS”
is their a way to black list this ? If so How ?
it is not a big deal just annoying to have something fill up my log that I really do not need

What’s the output of:

sudo dmesg | grep sgx

when I type in that command " ```
sudo dmesg | grep sgx
I get nothing , no info , nada :slight_smile:

It’s case sensitive, so try:

sudo dmesg | grep SGX

well when I type in

sudo dmesg | grep SGX

I get

0.081380] x86/cpu: SGX disabled by BIOS

just curious , what does this accomplish ? :slight_smile:

I fixed your horrible formatting. :wink:

When pasting terminal output, highlight it and use the Preformatted text </> button.

Alternatively, add three backticks ` above and below the text:


You just found out what it accomplished. Apparently nothing more than you already found. One line does not “fill up your log”. It’s not an error, just an informational message. There may be an option in your BIOS settings to enable the feature, but I would research it to see if you want that or not.

sorry I asked was hoping to solve the issue by blacklisting the bios feature that asrock decided to disable and hide in their bios . But that is ok maybe another forum can help instead of wasting my time with useless posts that do nothing. Thanks all the same You have a nice day ! :slight_smile:

Just a simple search gave me this:

check if isgx is loaded:

lsmod | grep isgx

or full list:


Blacklist a module: Kernel module - ArchWiki


thanks for the link but that did nothing , my problem is my journal just keeps filling up with this error message . No option in the bios to correct .
when I run
“sudo journalctl -p 3 -xb”
I get this error

Journal begins at Sat 2021-06-05 07:20:36 EDT, ends at Mon 2021-06-07 13:35:>
Jun 07 13:23:55 brothergc-tobefilledbyoem kernel: x86/cpu: SGX disabled by BIOS
was hoping todays release of the new 512 kernel would fix it , but no joy
on a positive note better support for intel Z590 as drivers are now starting to show up

ok I finally got this fixed . The fix is upgrading the CPU from 10th gen comet lake to 11th Gen Rocket lake
turns out that Asrock disabled SGZ for all CPU’s and hid the option or even not supported the option for Comet lake . I tried to contact Asrock support and they said that the Z590 boards do not support Intel SGX . I even sent them a screen shot of the error . That is when they figured out I was running Linux and just blamed it on Linux . What a bunch of A-holes . They then just shut Me off .
The problem is NOT with Linux but with their bios , or lack their of because Linux cant pick up something that is not their a fact that the tech support refuses to acknowledge and instead just wants to blame linux in order not to deal with a issue that is their .
Long story short I would not recommend using a 10th gen comet lake on ANY of their boards . Not only because of the SGX issue but their bios is geared toward rocket lake . I had many voltage setting issues with comet lake that disappeared with rocket lake .
That being said , the board is running awesome with Kernel 5.12.9-1, many of the drivers are their even my western digital sn850 has drivers . I highly recommend Asrock boards running Manjaro , all sensors work out of the box . Tip I found get rid of power top and TLP , great for laptops but for desktop not so much

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.