How to assign drive letters to /sde?

hello bonjour… im a french Canadian happily residing in Philippines, please forgive me if my english isnt UK perfect…

i have manjaro plasma i think… and this pc has 5 additional hdd’s plugged into it, on top of the main pc ssd… 1 hdd is formatted to gpt… lets call it… /sde … i am trying to install world of tanks using wine but of course the ssd has insufficient space for a 60gb game so i want to slap it into /sde a 250gb hdd… but it keeps saying cannot access it… although it can read how much space is available… any help please… ? and yes it is mounted…

merci, thank you…

So /sde is already mounted and you configurated it with winecfg as drive D: ?
Do your user has write permission to that directory?

Or you can start from scratch and tell wine to create the prefix for WoT in the directory where /sde is mounted…

i think i do, please see for yourself dude :slight_smile:

Verify by executing:

$ wine cmd

then on the prompt:


does it switch to:


? If yes, then does it have Games folder? If not then mkdir it:

D:\>mkdir Games

then try installing again.

got a command prompt… and i did the following and it tells me something that i cannot understand


wine: Read access denied for device L"\??\d:\", FS volume label and serial are not available.
Volume in drive d has no label.
Volume Serial Number is 3fc2-3aac

Directory of d:\

03/22/2024 07:31 AM lost+found
0 files 0 bytes
1 directory 232,473,382,912 bytes free


This is the top google result, which a follow up is to check:

$ ls -l ~/.wine/dosdevices
1 Like

If your Linux moutpoint is readonly then your wine cannot write to it.

You will need to ensure your user has write permissions on the mountpoint.

no such file or directory…

how do i give permission to have write also ?

i got this from /dev/sde1

brw-rw---- 1 root disk 8, 65 Mar 22 09:57 /dev/sde1

i think i cant write to it…
please give me the chroot cmd to fix this…
i tried sudo chmod u=rwx,g=rwx, o=/dev/sde1

and it didnt work

according to google, i need to take ownership of this hdd… but i believe that is for ubuntu…

That’s for nay linux fs. You can take permission with
sudo chown <user>:<group> <path>

Then make sure you have read/write permission with
sudo chmod +rw <path>

This is optional, but I’d install the game in its own Wine instance:
WINEPREFIX=<path-to-drive/folder> wine <path-to-installer-executable>

This will create an individual wine instance and install the game there.

1 Like

You don’t write to the device file (or change the permissions), you mount it and write to the mount point. You change the permissions on the mount point.

That command you tried is nonsense. It should’ve been something like:

sudo chmod ugo=rwx /path/to/mountpoint

# or

sudo chmod 777 /path/to/mountpoint

So take ownership of the mount point:

sudo chown $USER:$USER /path/to/mountpoint

1 Like

:point_up_2: this! I assumed the drive was mounted! You can do it with
sudo mount /dev/sde1 <path-to-mount-folder>

You can mount it manually on any folder of your choice or do it using the desktop/file manager gui tools.

1 Like