How to add nvidia-drm.modeset=1 kernel parameter?

For full Wayland support on Nvidia with Plasma, one needs to enable the DRM kernel mode setting, by adding kernel parameter


I’m searching and searching for half an hour and cannot find any info how to do it. People always just add that they added it, but never how. I found some command that does this, but this is from Ubuntu and I don’t know where is this change located, so I would prefer to do it by hand in some config file, if possible.

This looks like something obvious, but it’s not. It’s either 'I just added it" or full info about trillion of things, but never this.


Try adding “arch” to your search. :upside_down_face:
click the links inside the wiki, they lead to what they are talking about, in this case kernel mode setting

Wait, wayland, nono, well, yes, but you prob need more than that, but I see a person typing so I’ll leave it over to that person, and go to bed.

Good luck!

1 Like

Of course, I was adding “arch” to my searches. I read through tons of arch wiki articles, but they all are written by those golden rules:

  • if something is simple, god forbids to write about it
  • if something is complicated, esoteric - sure, write all you want

I just need FILE AND LOCATION where to put nvidia-drm.modeset=1 and in which place. None of the files or places have anything similar.

Also, I found in /etc/modprobe.d/mhwd-gpu.conf a line:

blacklist drm

Should I remove it to enable drm? We need to remeber, that MHWD is something that Arch doesn’t have, but it affects the GPU. Previously, optimus-manager was doing it and MHWD was disabled. Now I am reverting to default MHWD setup, but I miss some Wayland features, so it is possible that MHWD is the place where to solve it.

Edit GRUB configuration file

sudo nano +6 /etc/default/grub


GRUB_CMDLINE_LINUX_DEFAULT=“quiet udev.log_priority=3 nvidia_drm.modeset=1”

Use Ctrl + O to save file; Ctrl + X to exit nano and then update GRUB

sudo update-grub



@michaldybczak C’mon, you’ve been around long enough to know better. Did you miss this fine tutorial?

@bedna just linked the relevant wiki articles.

@nikgnomic just spelled out what to do.

However, that’s not the only way to do it. :wink:

Thanks, @nikgnomic, but I want to test something first.

Let me explain. Previously, I had optimus-manager and secondary monitor worked for me on Wayland without problems. After optimus-manager is gone, it doesn’t. The GRUB conf was the same then and now, so the solution may not be a change in GRUB. Optimus-manager was disabling MHWD confs to provide own ones. Now that those are gone, I reinstalled MHWD nonefree drivers and MHWD confs returned. My guess is, that a change in one of them is the key to restore proper multimonitor support in Wayland.

Here are MHWD files I found:

/etc/X11/xorg.conf.d/90-mhwd.conf - symlink

/etc/modules-load.d/mhwd-gpu.conf has:


but /etc/modprobe.d/mhwd-gpu.conf has lines:

blacklist drm_kms_helper
blacklist drm

Are those blacklisted drm’s not blacklisting nvidia-drm?
Also, if I need kernel module and mhwd is providing it already, it could mean, that this is not a matter of this kernel parameter but something else.

I saw those articles tons of times and there were not helpful. Why do you think I started this topic?
Because some solution was provided, it doesn’t mean this is a correct one for me, however, it may be a correct one for the question I asked in the first place ;).

To solve an issue, I must understand some things first, and arch wiki omits almost all most important stuff. It’s like in a cake recipe without ingredients.

That’s nice. You did not tell us that. How are we supposed to know what you read or what you did?

Anyway, you can flail about wildly on your own. I’m done here.

EDIT: Sorry if that comes across as rude, however it’s straightforward. This is now your third topic that does not contain enough information in the last day or two. I’ve helped out the best I can (which may be limited as I’m not feeling that well).

Unfortunately, this stopped the graphics to load. I had to revert the change from tty.

I found a topic that this was exactly suggested and helped:

Unfortunately, this probably collides with MHWD. I need a Manjaro specific solution.

This isn’t fair. I already created a full topic about it. I spend time including as many things as possible, but no one responds, because no one wants to read topic that are overly abundant with data.
I thought I just ask this one, very specific thing. Because everywhere this is treated as something obvious, I hoped to get a straight forward answer. No background or enplaning needed.

So either it’s too much and too complicated or too little. How about, I explain things as we go, because this is an only way to proceed with such things. Besides, when did you see a perfect support question with all the needed data where a simple arch wiki article helped right away?

I have a problem, that I’m spending many hours and I require some help, suggestions, to point me in the right direction or help me to understand some things.

Now I see, that my topic name was too vague. There is arch wiki article how to add kernel parameters, but it explains that it can be done in many ways. However, I have one parameter that I need to put in a proper place. GRUB was not the answer. Or maybe it was, but probably this parameter must be named differently there.
It’s like having a puzzle piece but not know to which puzzle set it fits. In the end, it may turn out that the puzzle is not what I wanted, and need to start anew, knowing that this is not the way.

You might be right, however please put yourself in our shoes.

I do! :raised_hand:

However, I haven’t been feeling well lately and am wiped out. Sorry I couldn’t be more helpful.

I’m off to watch some more Stargate SG-1. :wave:

In the future, test kernel parameters one time first. On the grub menu screen (if you do not see it i think shift or esc shows it) hit e to edit the entry and add the parameter. If something goes wrong just restart, change does not persist

1 Like

Thanks. Don’t feel forced to help.

Usually, if old Manjaro users like me start a support topic, there is a high chance that the issue is complicated and a couple of arch wiki articles rarely helps. Besides, during hours of search, one comes across many questions, concepts, so needs are constantly changing. This topic was meant to answer on one of them. Now I feel it is a dead end. I found another topic on reddit, that suggested the same solution as @nikgnomic showed and it was a success. So I guess, this won’t help me, because it looks like MHWD is already providing this module, so the issue is elsewhere. This is off-topic thou.

If you read it later and want more background, I’ll try to explain it in short:

I’m, moving from optimus-manager setup, that worked for me well for the last 4 years. At this point, all is working (I can access Nvidia on X11 and Wayland with prime-run), except secondary monitors on Wayland (works on X11 thou). This worked fine on optimus-manager setup. There seems to be one thing missing (config, parameter) and I’m trying to figure out what. Topics, that I found, on secondary monitors not working on Wayland, are not helpful so far. Manjaro graphics works a bit differently thanks to MHWD, so it’s hard to understand all the connections. Especially, Wayland is harder to grasp.

I have no idea about optimus manager. All I have read that it is a hacky way to get stuff working so I avoided it when setting up my nvidia.

If you have added the modules like I linked to and added the stuff in grub I have no idea.

It does seem you are missing nvidia.conf, I have no idea where your symlink in xorg.conf.d points to, but if you have read the links I posted so many times you feel offended by me posting them I can only assume it’s by your design so I have zero clue what to do.

Sorry, good luck.

Well, there is /etc/modules-load.d/mhwd-gpu.conf which provides loading:


So, my question is the kernel parameter nvidia-drm.modeset=1 just another way to load nvidia-drm or something else? If this is the same, this would explain why adding it to GRUB was causing some conflicts.

As to optimus-mangager, it was a bit hacky, but not as much. The base thing it provided was driver configs in /etc/X11/xorg.conf.d/ that could be switched during session reload. So nothing too complicated. Of course, it provided various nvidia offload methods, so those things were saved in another config or provided within graphic config in /etc/X11/xorg.conf.d/. Additionally, nowadays, where there are no graphical configs, in /etc/X11/xorg.conf.d/, it all still works by using defaults. Optimus-manager provided with excellent and issue free experience, so let’s not demonize it. The problem is, that it isn’t developed anymore and things are changing. Wayland a few years ago was not the same thing. My old graphical configs are not working well now. In the past, I could revert optimus-manager and use my old configs and didn’t care about Wayland. Now, it’s a bit different. So some things optimus-manager did incredibly right if all was working so well. Now I have to recreate it more statically (permanent hybrid setup), but even using the same configs as optimus-manager provided, isn’t doing the same thing, so I am still missing something. Because the issue is basically with Wayland and this is dependent on kernel mode settings, the resolution lies probably there.

I have /etc/X11/xorg.conf.d/90-mhwd.conf symlink which points to /etc/X11/mhwd.d/nvidia.conf, which is empty, because MHWD uses defaults. As I understand, this nvidia.conf is there only to pass through some nvidia settings from nvidia-settings tool, as described on MHWD documentation page. I don’t think it’s relevant here, because those are still X11 settings, not Wayland ones. Also, as said earlier, specific xorg settings are not needed, because modern DEs configure monitors differently and if there is no need for very specific and unusual settings, those are not needed.

I’m not offended. In this topic here, I asked for a very specific answer and I didn’t get it and those links are not showing it either, at least not directly. I have to study all graphical articles to make a head or tail out of this, so this isn’t that much helpful here. It’s like asking for a specific recipe, and you gave me some cookbook with general rules that doesn’t have this recipe (one could possibly figure it out, but it requires a long process of learning and experimenting). However, I understand, that you just wanted to be helpful and counted that I will figure it out myself using those links.

Anyway, forget about those and focus about me understanding nvidia-drm.modeset=1, so I could figure it out. This is very confusing to have kernel parameters, kernel modules (which can be added in multiple places), kernel mode settings - my head spins. I need to analyze it one thing at a time.

Kernel modules seem to be obvious. Those are run through confs in /etc/modules-load.d/, although modules are also mentioned in /etc/mkinitcpio.conf. Are those simply alternatives or working differently?

Kernel parameters seem to be a complex thing and can be put in various places.

Kernel mode settings - so far I don’t understand what I read. It just doesn’t make any connections to me, because I miss some ground knowledge. I’ll try to study it further. My basic question here would be: is Wayland using Kernel KMS or Nvidia’s own KMS?

Wiki says:

" The proprietary NVIDIA driver supports KMS (since 364.12), which has to be [manually enabled."

This leads me to this section:

To enable DRM ([Direct Rendering Manager], set modeset=1 and fbdev=1 [kernel module parameters]for the nvidia_drm module.

If I read this right: to set this KMS, one needs to set parameter for kernel module in /etc/modprobe.d/ .
Syntax is: options module_name parameter_name=parameter_value

What is the module name then in my case?

So far I know I should use

options nvidia_drm modeset=1 fbdev=1

This can be put in any conf in this location, so can I put it in /etc/modprobe.d/mhwd-gpu.conf ?

Or maybe it is better to create own config, so it wouldn’t be overridden by MHWD?

Also, various interactions between those elements make it all more complicated.

So far I know I should use
options nvidia_drm modeset=1 fbdev=1

Files in /etc/modprode.d/ are read in numerical-alphabetical order

To read the modeset .conf file after mhwd-gpu.conf

sudo tee /etc/modprobe.d/nvidia-modeset.conf <<< 'options nvidia_drm modeset=1 fbdev=1'

If that does not work, change the name to drm-modeset.conf so it is read before mhwd-gpu.conf

1 Like

I think you understand wrong, it is the nvidia config.
I use the tool that is made for this, nvidia-xconfig as described on the wiki page.

Heard of xwayland?
I am not particularly interested in being the first test person when it comes to nvidia and wayland so I might be wrong here.
I have both wayland AND X11 installed and wayland launches just fine, I would assume under xwayland with my x11 nvidia configs.

At least ALL info I provide is exactly descripbed in the wiki links I provided. I’m sorry, not sure how you can miss it.

There are CLEAR examples in the wiki, are we reading the same document??

I don’t think you SHOULD forget about them, because I think they are the reason. And that line goes into the GRUB config exactly like described earlier. If it fails, it’s most likely because you have no nvidia.conf

Again, do you have the modesetting module loaded like described in the wiki? You provide almost nothing to go on here.

If you ask what modules to load:
IN :clap: THE :clap: WIKI :clap: Kernel mode setting - ArchWiki

I really can not help more, I might even be wrong in some things, but it works on my setup the way I described.

I added:

options nvidia_drm modeset=1 fbdev=1

to /etc/modprobe.d/nvidia-modeset.conf

The result was, that graphical environment didn’t start, similarly like I tried it with GRUB option.

I checked, and the issue is always with nvidia_drm modeset=1, because when I leave only fbdev=1, Xorg starts normally. I didn’t try to change the order yet, but I think it should be loaded after mhwd, which ensures that nvidia is loaded. Having nvidia options before loading nvidia seems pointless, but I may be wrong, as I don’t understand all the dependencies how it all works.

I’ve been thinking. This may have nothing to do with nvidia, but with modesetting driver, because on a hybrid setup, nvidia is launched on demand and everything else runs in Intel, including other all monitors, also on Wayland. This means, I have to look up closer to modesetting settings.

please post the output of

echo $XDG_SESSION_TYPE && glxinfo | grep server

and the mandatory

inxi --admin --verbosity=7 --filter --no-host --width

to see what gui etc … you’re using

for this you need >545.x

Grub cmd : nvidia_drm.modeset=1 not nvidia-drm.modeset=1

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 6.6.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=05f58c13-0021-44f7-abc9-05a091c4535b rw rhgb quiet
    mitigations=off quiet splash loglevel=3 udev.log_priority=3
    vt.global_cursor_default=0 resume=/dev/sda4 resume_offset=1363968
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Alienware product: Alienware 17 R3 v: 1.13.1
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Alienware model: 0GH72M v: A00 serial: <superuser required>
    UEFI: Alienware v: 1.13.1 date: 06/10/2021
  ID-1: BAT1 charge: 39.4 Wh (100.0%) condition: 39.4/90.0 Wh (43.8%)
    volts: 16.5 min: 15.0 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: full
  System RAM: total: 8 GiB available: 7.63 GiB used: 4.3 GiB (56.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 800/3500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 41621
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling status: Vulnerable: No microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Vulnerable
  Type: retbleed status: Vulnerable
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:191b class-ID: 0300
  Device-2: NVIDIA GM204M [GeForce GTX 960 OEM / 970M] vendor: Dell
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-11; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:13d8
    class-ID: 0302
  Device-3: Sunplus Innovation Integrated_Webcam_HD driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:5
    chip-ID: 1bcf:2b8c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x0459 built: 2014 res: 1920x1080 hz: 60
    dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 530 (SKL GT2)
    device-ID: 8086:191b memory: 7.45 GiB unified: yes
  API: Vulkan v: 1.3.269 layers: 9 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 970M driver: nvidia v: 545.29.06
    device-ID: 10de:13d8 surfaces: xcb,xlib
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
  API: ALSA v: k6.6.3-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet driver: alx
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 3b:00.0
    chip-ID: 1969:e0a1 class-ID: 0200
  IF: enp59s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer Wireless-n/a/ac 1535 driver: ath10k_pci
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0
    chip-ID: 168c:003e class-ID: 0280 temp: 57.0 C
  IF: wlp60s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:4
    chip-ID: 0cf3:e300 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 2.73 TiB used: 1.16 TiB (42.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SKC2500M82000G
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: S7781101 temp: 33.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A3P0 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  Message: No optical or floppy data found.
  ID-1: / raw-size: 100.59 GiB size: 98.82 GiB (98.25%) used: 62.88 GiB (63.6%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p4 maj-min: 259:3 label: N/A
    uuid: 05f58c13-0021-44f7-abc9-05a091c4535b
  ID-2: /home raw-size: 1.72 TiB size: 1.69 TiB (98.42%)
    used: 552.36 GiB (31.8%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:1 label: N/A uuid: 6f363872-d712-4728-920d-043fb9e3a885
  ID-3: /mnt/home-hdd raw-size: 670.14 GiB size: 658.56 GiB (98.27%)
    used: 574.25 GiB (87.2%) fs: ext4 block-size: 4096 B dev: /dev/sda4
    maj-min: 8:4 label: home-hdd uuid: 3d3bc3be-74d2-439d-8d1b-8b670faa9e05
  Kernel: swappiness: 20 (default 60) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-2: swap-2 type: zram size: 1.53 GiB used: 8 MiB (0.5%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  ID-1: /dev/nvme0n1p3 maj-min: 259:2 size: 200 MiB fs: vfat label: N/A
    uuid: E9F8-9190
  ID-2: /dev/sda1 maj-min: 8:1 size: 500 MiB fs: vfat label: ESP
    uuid: 843E-7168
  ID-3: /dev/sda2 maj-min: 8:2 size: 128 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/sda3 maj-min: 8:3 size: 250.44 GiB fs: ntfs label: OS
    uuid: 768C0B7F8C0B38DF
  ID-5: /dev/sda5 maj-min: 8:5 size: 844 MiB fs: ntfs label: N/A
    uuid: A4BEA64BBEA61638
  ID-6: /dev/sda6 maj-min: 8:6 size: 9.49 GiB fs: ntfs label: Image
    uuid: 000A60EB0A60DF62
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-2:2 info: Logitech Unifying Receiver type: mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c52f class-ID: 0300
  Device-2: 1-4:3 info: Alienware AW1517 type: HID driver: hid-generic,usbhid
    interfaces: 1 rev: 0.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 chip-ID: 187c:0528
    class-ID: 0300 serial: <filter>
  Device-3: 1-5:4 info: Qualcomm Atheros QCA61x4 Bluetooth 4.0
    type: bluetooth driver: btusb interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 0cf3:e300 class-ID: e001
  Device-4: 1-7:5 info: Sunplus Innovation Integrated_Webcam_HD type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 1bcf:2b8c class-ID: 0e02
  Hub-2: 2-0:1 info: super-speed hub ports: 8 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 48.0 C pch: 56.5 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 259 Uptime: 1h 7m wakeups: 0 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 2077 pm: pacman pkgs: 2044 libs: 534 tools: pamac,yay pm: flatpak
  pkgs: 18 pm: snap pkgs: 15 Shell: Bash v: 5.2.21 running-in: konsole
  inxi: 3.3.31

in /etc/mkinitcpio.conf
HOOKS=(base udev autodetect modconf kms keyboard keymap block filesystems fsck)

In X11:

echo $XDG_SESSION_TYPE && glxinfo | grep server
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

In Wayland:

echo $XDG_SESSION_TYPE && glxinfo | grep server
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

Above 545? I thought that 545 are the newest ones.

I rechecked and added nvidia_drm.modeset=1 in GRUB and had the same result - graphics didn’t start. I start to believe that this setting is for NVIDIA only systems, not for hybrid graphics.

okay, just to make sure, post the output of

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT

from here the modeset is not set as kernel parameter, but post the output first and it wouldn’t effect anything while you are still running the intel-graphics.