How to add a new keyboard input language to i3wm?

Please help me add a new keyboard input language to i3wm

Have you added the locale yet using Manjaro Settings Manager? I believe you should do that first. As for switching keyboards while working, I’ve got this line in my i3 config that let’s me toggle between English and Arabic using alt+shift:

exec --no-startup-id "setxkbmap -model pc105 -layout us,ar -option grp:

Just substitute the code for the language you want where the above has “us,ar” for US English and Arabic. I believe this will work for more than two options as well. The line in the config might just work independently of adding a locale at the system level, but I’m not sure about that.


Thank you @drhoopoe, exactly what I was looking for; I will try this first and let you know how it goes!

This didn’t work @drhoopoe; I have the other language added in Language Packages (and Locale Settings just to be sure) but it won’t switch to it via hotkey that I added to i3 config

I have only one setting in .xprofile

setxkbmap -layout “us,ru” -option “grp:alt_space_toggle”

grp: is option to switch your layout groups, I love to use alt+space to toggle between languages. More combination you can find in (just look up grp:)


I you want flag indicator in your tray area, you can use package gxkb and invoke in same place (.xprofile) as

gxkb &

Oh, and I don’t have specifically installed anything in my language, except aspell dictionary.

So what ended up working was this in config:

exec --no-startup-id setxkbmap -model pc105 -layout “us,ar” -option “grp:alt_shift_toggle”

I basically combined both @drhoopoe’s and @EffToyz’s solutions: removing the line break from the former and editing the quotations to fit the latter (it may work without the quotations but I didn’t bother testing)

1 Like