How to add a network printer?

I just spent the entire day downloading and installing Manjaro 21.0.3 - Mate . So far, I love it, but, I have just discovered that there seems to be no way to add printers. Yes, I know that it can be done (the hard way) through the terminal, but virtually all other Linux distros have a VERY simple setup, usually not requiring more than two or three clicks, and about thirty seconds. So far, I’ve wasted 2 hours, and I’m no closer than when I started. Something is wrong here. Can anybody help?

Perhaps Printing - Manjaro

1 Like

And yet, Manjaro is the only Linux in which I could get printing to work. And rather easily as well.

Edit:

Check out the manjaro-printer package, if you haven’t yet. I’m sure it’ll help.

1 Like

I have a HP printer with pretty good networking capabilities connected to our home wifi. Manjaro had HP Device Manager preinstalled for me and at first the auto detect wouldn’t work. However, turning off the firewall fixed this, it now works fine with the firewall on.

So I guess:

  1. See if your printer has any manufacturer supplied Linux software available
  2. Disable your firewall when you attempt to set it up for the first time

If you prefer using a polished gtk app you can install system-config-printer too.

1 Like

Thank you. Yes, I looked at that document (Printing - Manjaro) again. It gives two alternative methods of setting up printers: “Webpage Interface” or “Desktop Interface”. Both of these fail right out of the gate. When I attempt Webpage Interface, I get the reply “Unable to connect to localhost:631”. And when I attempt to use the Desktop Interface, I find that there is no “Print Settings” item to select anywhere in my desktop menu. Is this some sort of sick joke?

Please see my reply to Stargazer, who made the same suggestion, to check out Manjaro-Printer. I’m fairly experienced, but this has me stumped.

Make sure the cups services are installed and started, considering the webui gives that error.

1 Like

I’ve had some success by installing (and starting) avahi services to get the gnome printers app to see my old canon network printer and scanner.

Use these commands to enable and start:

sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path
2 Likes

Did you start the cups service(s)… You’ll get “Unable to connect” if not started.

sudo systemctl enable --now cups.service cups.socket cups.path

NOTE: you can change enable to status (and remove the --now)

  • What type of printer
  • How is the printer connected to the system (usb, network)

I didn’t have the Desktop Interface installed. It appears to be coming from the package Print Settings (system-config-printer) which is an optional dependency of manjaro-printer. There is a different print manager for KDE (print-manager). The meta package, manjaro-printer is pre-installed, the user never will see the dialog for the optional dependencies, which happens to include system-config-printer.

This can be seen via pacman -Qi manjaro-printer or from pamac. In pamac enter manjaro-printer in the search textbox and then select it and scroll down to “Optional Dependencies”.

To summarize

  1. Enable cups in systemd (should already be installed)

  2. Make sure system-config-printer is installed

  3. Go to the Whisker menu and type print in the search textbox and select Print Settings
    This is in the doc… And then you should be able to follow the rest of the documentation at “CUPS Desktop Interface Part 1: The Automatic Method”.

    • NOTE: In the upper-right-hand corner there is a toggle to lock and unlock the dialog. The dialog seems to lock immediately after adding a printer. You might have to unlock it. Be patient some of the operations are slow.
1 Like

Thanks to all, especially Stargazer. The problem is now solved.

  1. I made sure that CUPS was enabled, (It was.)
  2. I made sure that manjaro-printer and Print Settings (system-config-printer) were installed, (They were.)
  3. I ran “status” in place of “enable”, (minus “–now”). (I got lots of interesting data, which I did not understand.)

Those were all good suggestions, but what fixed the problem was that, while I was in pamac, trying to verify that manjaro-printer and Print Settings (system-config-printer) were indeed installed, I decided to search the term “printer”. Not too far down the list I found print-manager 21.04.0-1. That sounded good to me, and since I was out of ideas, I decided to install it. Lo and behold, my problem vanished. I noticed a new menu item called “Print Settings”, which I didn’t have before, and when I clicked on it, I was able to install both of my printers, and successfully print test pages. [I have to wonder why that wasn’t included in the installation package.]

So, that’s the end of my story. I’m not actually sure what fixed my problem, but it seems like installing print-manager is what did the trick. To give credit where it is due, I would not have stumbled onto the solution without Stargazer’s suggestions.