How to activate max/fixed performance boost with Intel 6700k CPU?

Hello guys,
I have a 6700k overclocked @4700Mhz, i don’t want that my Intel CPU downclock to 800Mhz in idle
i’m looking for a fixed 4,7Ghz clock.

Is there maybe a terminal command for that? Because i can’t find any solution in Powersavings GUI in KDE.

Maybe intel_pstate (performance mode) could help? But i have no clue how to set this up, that it will working after a reboot.

Thanks in advance.

Edit: I want to limit my CPU on 4600Mhz and in performance mode if that’s possible.

You have 3 possibilities for that.

  1. Either do it in your UEFI

  2. Set the minimum cpu frequency

  1. Change the governor for “performance”

cpupower frequency-set -g performance

But i will advise you to NOT set max frequency for all cores.

cpupower frequency-set -g performance -c <core_number>

1 Like

Why not? I have my system running over 5 years now in Windows with 4700Mhz all the time.

OK, if your overclocking is stable at this stage for all cores, do it like that :slight_smile:

Unless you overclocked manually, usually, the frequencies are not the same for each core, it’s maybe not the case for you.

If i try your performance command cpupower frequency-set -g performance it works only temporary right? I have to put it in autostart?

I have 4700 on all 4cores and 4 HT.

The governor, maximum and minimum frequencies can be set in /etc/default/cpupower.

1 Like

My changes won’t be acceppted from /etc/default/cpupower after restart.

# Define CPUs governor
# valid governors: ondemand, performance, powersave, conservative, userspace.

# Limit frequency range
# Valid suffixes: Hz, kHz (default), MHz, GHz, THz

# Specific frequency to be set.
# Requires userspace governor to be available.
# Do not set governor field if you use this one.

# Utilizes cores in one processor package/socket first before processes are 
# scheduled to other processor packages/sockets.
# See man (1) CPUPOWER-SET for additional details.

# Utilizes thread siblings of one processor core first before processes are
# scheduled to other cores. See man (1) CPUPOWER-SET for additional details.

#  Sets a register on supported Intel processore which allows software to convey
# its policy for the relative importance of performance versus energy savings to
# the  processor. See man (1) CPUPOWER-SET for additional details.

# vim:set ts=2 sw=2 ft=sh et:

cpupower frequency-info showed still this, like nothing changed:

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 4.70 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 800 MHz and 4.70 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 800 MHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

Please help :confused:

that’s how i did it:

sudo cpupower frequency-set -g performance
nano /etc/default/cpupower

systemctl enable cpupower.service
1 Like

what about:



i didn’t touch those,
just set it to max.

(my CPU is not overclocked)

To enable the service fixed the problem… thanks alot for the help… now even min and max settings works :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.