How do you find a files' full path to use in a desktop launcher for wine?


I’m new to Linux (is) and v new to Manjaro. I am trying to get a v old windows app called Paint Shop Pro 7 to work via wine.

It installed fine and ran from the installer once, erm… installed (there was a run option at the end). It will run from the command line with wine, when I am in the application’s directory. However the path is full of spaces and I am not sure how to get it into a desktop launcher. Have tried:

/bin/wine /home/John/.wine/drive_c/Program\ Files (x86)/Jasc\ Software\ Inc/Paint\ Shop\ Pro\ 7/psp.exe

but it does not work and am not sure I have the path correct.

How can I see a files’ full path?

If there are spaces in the filename and/or the directory name, then you should enclose the entire path between single or double quotes. Something like… :arrow_down:

/usr/bin/wine '/home/John/.wine/drive_c/Program Files (x86)/Jasc Software Inc/Paint Shop Pro 7/psp.exe'
1 Like

Many thanks, problem is I’m not sure I am using the correct path - I suspect a typo - is there any way of finding a files path?

Yes, by way of locate. :arrow_down:

locate text-string-here

You can further filter that, if you like. So if you only want the output of things that reside in your $HOME, then you would use something like… :arrow_down:

locate text-string-here | grep "$HOME"

However, if what you installed is still new — i.e. less than 24 hours — then the mlocate database won’t be up-to-date yet, and then you have to do that first… :arrow_down:

sudo updatedb
locate text-string-here | grep "$HOME"
1 Like

Many thanks, that worked and yes there were typos :confused: The program now starts, but I’m getting an odd error in the shell window,

Read access denied for device L"\??\I:\", FS volume label and serial are not available.

Is this an issue or can I just ignore it? I don’t get this if I just start the app in a shell without using a launcher

Well, I don’t use wine or Windows, but I think you can probably ignore that.

FYI, each Wine application should have it’s own prefix (aka bottle). See Wine - ArchWiki

One easy way to manage Wine applications is Bottles. The only supported installation method (and easiest) is the official Flatpak. I don’t recommend the AUR (Arch User Repository) package as it will frequently break.

Mind you, I don’t normally recommend Flatpaks as I prefer installing programs build from source code; i.e., repo packages and building AUR packages. However this is an exception.

1 Like

As another FYI, instead of Paint Shop Pro, you can also use the GNU/Linux-native krita or gimp. Both are in the official Manjaro repository. :wink:


Pinta and Inkscape are also good for such purposes.

1 Like

inkscape might be overkill, though. pinta might indeed be closer to Paint Shop Pro. :man_shrugging:

1 Like

…error in the shell window,

Read access denied for device L"??\I:", FS volume label and serial are not available.

Could be the shell interpreting part of the path instead of using it literally.

If you enclose the path in double quotes, the shell interprets some part(s). To avoid that and have it all treated as a string, use single quotes.

If the path contains quotes, you enqoute the part before it, escape the quote, enquote the part after it. E.g. 'this is a user'\''s path', without spaces as in that example.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.