How do I update the kernel package on a Pinebook Pro?

Hello everyone, hope you’re all having a good winter, or summer, depending on your hemispherical affinity.

I’ve been tinkering on and off with a Pinebook Pro for 2-3 years now, give or take. I uh, just noticed that I’m still running 5.7.19-1-MANJARO-ARM. That kernel’s pretty old now, right?

If I run pacman -Qi linux, I happen to get

Name            : linux-pinebookpro
Version         : 5.7.19-1
Description     : The Linux Kernel and modules - AArch64 multi-platform
Architecture    : aarch64
URL             :
Licenses        : GPL2
Groups          : None
Provides        : kernel26  linux=5.7.19
Depends On      : coreutils  linux-firmware  kmod  mkinitcpio>=0.7
Optional Deps   : crda: to set the correct wireless channels of your country
Required By     : None
Optional For    : base
Conflicts With  : linux
Replaces        : linux-armv8
Installed Size  : 123.73 MiB
Packager        : Furkan Kardame <>
Build Date      : Wed 02 Sep 2020 01:40:06 PM EDT
Install Date    : Tue 02 Feb 2021 09:47:21 PM EST
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

I guess that would explain it. It says “Explicitly installed”. Did I do that? I wouldn’t remember.

Is there an official process to switch to an equally-supported newer kernel? Whenever I search for Manjaro kernel information, I wind up reading about x86 stuff, or misc. hardware support issues.

You can switch to the regular linux kernel package, which is currently at 6.1.X.

sudo pacman -S linux

and say y to replace the current one.

Looks like that worked. Nothing’s caught fire yet. Maybe this’ll fix that Firefox issue that was locking up the desktop.

(It did complain about a missing Plymouth hook. I ignored that error, didn’t sound important.)

Thanks :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.