How do I turn-off verbose logging during boot?

Hello guys,
When I installed Manjaro, the booting process would be non-verbose and I could see the login manager directly after POST. However, after updating Kernel, I now get a full verbose output before login screen is launched. The same thing happens while logging out. I would to like to turn off this behavior. Please help.
Changing grub to quiet has done nothing.
Thanks for any suggestions!

normally, the boot process is (relatively) silent
unless you changed the grub configuration
to not be silent

what could certainly help here - if you can’t figure it out - is:
post the contents of

/etc/default/grub

If you made no changes to it - the boot process should be … silent

… lets see what you have got

Here it is:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX_DEFAULT="intel_iommu=on"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

Merge the content of the second line into the first line. Then delete the empty second line.

After changing the file enter the command

sudo update-grub

and reboot.

1 Like

I did as advised.
Should I also delete the third line which has nothing but quotes?

No.
Leave it as it is - and perhaps read up on what this is used for.

Do as @Wollie suggested - I suspect that of the two identically named lines
with different content
GRUB_CMDLINE_LINUX_DEFAULT= ...
only the last one (the second one) is taken into account - thus the settings to make the boot quiet are not applied - only the
intel_iommu=on
setting in the latter line

1 Like

Excellent… this kind of clear and precise explanation is what makes this community great.
Thanks again for taking your time to explain! Kudos!

1 Like

Thanks worked like a charm.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.