How do I switch which Bluetooth adapter is being used? I have 2 of them

I’m new to Linux and Manjaro. I have 2 bluetooth adapters. One is a part of my ASUS motherboard and the other is my Intell wifi 6 card.
I am trying to turn off my ASUS bluetooth device for good and to only use Bluetooth via my intel wifi 6 adapter card. Any help would be greatly appreciated. Currently Manjaro is using the old ASUS Bluetooth adapter that is part of the motherboard. I verified this by turning it off via command “sudo btmgmt --index 1” then I used command “power off” and it disabled it. I know this via 3 ways. The sound to my Bluetooth head set went dead, the Bluetooth device was disconnected in the GUI Bluetooth section, and in “inxi -F” it showed the state of the ASUS adapter as DOWN. However when I try to reconnect to my headset via using the connect button in the GUI interface it doesn’t connect and says “device not ready”. Then check mark next to the enable Bluetooth in the GUI and then it shows me a button that says “enable” and it will then let me reconnect to my headset. But when I click enable it just turns back on my ASUS Bluetooth and connects to my headset. I can see this when I watch the rolling info in “sudo btmgmt --index 1” and verified via “inxi -F” and it shows as status UP again. Then I again turned off the ASUS device again just to see if it was the one that auto reconnected to my headset and my headset disconnected again.

Have you tried to disable one of the adapters with rfkill command? Just an idea.

From what I can find rfkill only kills all the Bluetooth adapters or none of them. The only other way I can find that might work is to use hciconfig, but that is deprecated from manjaro/arch and I would need to instead old stuff/tools to get those commands to work. I was hoping that the “new” btmgmt tools would have made this easier.

Can you turn off the motherboard bluetooth in the Bios?


I was just about to reply with the same suggestion. Not sure what motherboard the OP is using, but ASUS have this instruction page which may provide some guidance: [Motherboard] How to solve the Bluetooth problem of the motherboard? | Official Support | ASUS Global

1 Like

That helped a lot. Thanks! I found the option to turn off the onboard bluetooth in my UEFI settings. I just wish I could have figuered out how to switch divices using the terminal commands. I had found an option in btmgmt called “discov”, bugt when using it on the onboard and even on the other blutooth card it wouldn’t work. It just kept saying the command was rejected. At lease this way worked. Now I am sure that my new wifi 6 card works in it’s entirety and am now using a newer bluetooth adapter with better range. Thanks again for the suggestion. I didn’t know that the bios/UEFI had that option.

1 Like

Perhaps this helps:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.