How do i stop program from running on startup?

I want to disable some programs to run on startup.


Have you looked in Settings > Session and Startup > Application Autostart and uncheck what you do not want?

Some desktop files are placed in /etc/xdg/autostart - you can manually delete some, but will be reinstalled at update, so better use the settings above to disable them.
Others might be in your home directory ~/.config/autostart/
And then there are systend services …

If you provide more details about what you want to disable, someone might have more to say about this, and propose better approach.


Thank you for your nice reply.

Every time when I reboot my machine when I log in I see the “Konqueror” starts up .
I looked in /etc/xdg/autostart , ~/.config/autostart/ and the menu location you have mentioned above, but I didn’t see it. !!

Thank you for your kindness.

In your XFCE settings, there’s a section for Session settings. Make sure its set to boot with a new session and not a saved one.

Sounds like KDE to me.
Perhaps have a look here

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.